In one of our classrooms we have recently updates the SAP Client software. I am trying to create a GPO creating a shortcut on the machines that have this software installed. I have created a GPO and Mapped a shortcut as follows:

Action - Update (Have tried Create)
Name - SAPLogon
Target Type - File System Object
Location - Desktop
Target Path - "C:\program files\sap\sapsetup\setup\sal\saplogon.s8l"

All others are default although I have tried setting the Start In: path

Icon File Path - %systemRoot%\system32\shell32.dll
Icon index - 84

However every time I try this I do not get the Shortcut on the desktop. A Gpresult gives the error code 0x80070002 which is file not found. If I take the target Path and paste this into the "Create a new shortcut" windows on the local machine it resolves perfectly.

Is there something I'm missing. I've looked at the Technet articles and googled around but cannot find anything I'm doing wrong.

The DC is Server 2008 R2, machines are Windows 7

Any further details. - results of GPRESULT / screenshots etc please let me know


Try the "Replace" action - in my experience, it'll hopefully be a little less flaky.

Also, is anything on the Common tab set? Specifically, the Apply once and do not reapply setting may explain why a Create action didn't work.

I've also had a situation (involving a UNC path target with additional arguments, if I recall) where the "Shortcuts" client-side preferences settings were altogether unable to do what was needed; in that case, I gave up and simply created a master .lnk file in a network share, and set a "Files" client-side preference to make a copy on the user's desktop.

  • Copying the shortcut as a file worked, although I screwed it up at first by just putting the destination path as %desktopdir% and not %desktopdir%\Name.lnk. Thanks for your help. Annoying that the Shortcut won't work as it should. – Joe Taylor Oct 3 '11 at 12:25
  • 1
    Had the same error, turned out that I was pointing directly to an MS Access DB file. I had to put the MS Access executable in as the target path, and the filename as the argument. In addition, the filename had spaces in the name so in the argument field I had to surround the filename with quotes (but not the target path field which also had spaces). Once I modified it this way, it worked no problem. – yougotiger Sep 24 '14 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.