I've just started looking at using Squid for a project and can't seem to see an easy way of disabling the Squid error pages (e.g. "Name Error: The domain name does not exist"). We use a custom browser which handles that scenario in our way, so the Squid error pages are overriding our custom logic.

Is it possible to set them too 'off'? I've been through the .conf and I've found where the error pages are stored, but no real options to disable them.


If you are moving from not using a proxy to using squid there are some functions that your browser will no longer be completing.

Using the "Name Error" you mention as an example...

Without a proxy, the browser will attempt a DNS name lookup from the local resolver and it will fail which results in a local application error.

When you use a proxy your local browser does not do DNS name lookup. It opens a connection to the proxy and sends it the URL, so the proxy does the lookup, has the resolver error then sends a http response back to the browser as that is the only interface between the two.

You can always copy and modify the squid error pages to match your browser (somewhere like /usr/share/squid-langpack/templates and then set error_directory). Or further customise your browser to provide your custom error messages for particular http error responses from squid. You may need to create simpler tags in the squid error pages that your browser can match easily.

| improve this answer | |

probably http://wiki.squid-cache.org/Features/ICAP that will help you

| improve this answer | |
  • Thanks, I've actually discovered that the error pages can't be turned off, but I'll have a look to see if ICAP can help solve our issue. – Nicholas Smith Oct 3 '11 at 12:26
  • I'm also interested how you turned off :) Can you tell me please? – mazgalici Oct 3 '11 at 12:33
  • Well there's no actual way to turn them off, as once Squid has been contacted it has to send a response. The only way it seems to do it is create custom error pages using their templates and go that way. – Nicholas Smith Oct 3 '11 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.