I am currently experiencing a connection issue that occurs exactly every 10 minutes (give or take a few seconds).

I have a Lynksys WRT150N with DD-WRT v24-sp2 std. I have verified this is not an ISP issues as it occurs on the internal LAN and when taking the personal router out of the mix everything works fine.

This issue is a relatively minor connection problem as in almost all applications I use you cannot notice the problem. I only discovered this problem when I was taking an online SANS course and the class streaming application would drop connection every 10 minutes exactly.

I decided to run a ping test where I basically just pinged Google continuously. (ping /t www.google.com). I found that every 10 minutes I would get either a "Request timed out." or a "Reply from Destination net unreachable." error (no noticeable pattern as to which one would occur over the other). This would only happen for one ICMP packet at the 10 minute mark and then it would resume as normal.

I have tried updating the firmware (upgraded to the v24-sp2, had an older version before that). I made sure to do the hard reset 30/30/30 before and after the upgrade. I have tried scouring for answers everywhere I could think of. The closest thing I found was this post:

What causes a TCP/IP reset (RST) flag to be sent?

Of course that only relates in that the RST flag they are getting is happening every 10 minutes (though I am curious as to whether their issue is in fact a TCP issue or the same problem I am having affecting more than just the TCP layer; they too have a WRT router).

At this point I am considering just getting a new router but I find it hard to believe this is a hardware issue which causes a connection drop at such a regular interval.

Any help you can provided is much appreciated. Apologies in advanced for any misconceptions or lack of information on my part.

  • This is really a question for Server Fault. Oct 2 '11 at 0:44
  • @Surfer513 Indeed it probably should be, my apologies. I was looking at the linked article when I posted the questions. If I recall there is a way to move questions to Server Fault now. Would you happen to know how I would do that?
    – New Guy
    Oct 2 '11 at 0:51

"Ten minutes" is the giveaway here -- it's some periodic operation being done by human direction. That's 600 seconds, so I'd be very tempted to look for some kind of flow-metering.

Given that, I did a little googling and found this:


Google is your friend.

  • I have in fact tried Google. :) My max ports is set at 4096, TCP timeout set at 3600 and UDP timeout set at 120. (These are the defaults.) There is no mention of 600 seconds in any of my configurations.
    – New Guy
    Oct 2 '11 at 1:00

I know you have not been able to reproduce the problem if you remove your router from your network path but have you verified that this problem exists with other clients? I would ensure that you can reproduce this problem on more than one client (try your ping test on another machine) before you continue with the assumption that the router is underlying problem (although it likely is).

DD-WRT has never really impressed me as a very stable platform. It's hard to tell whether that's a result of the COTS-nature of the hardware it gets run on, DD-WRT itself or a combination of the two. Regardless a quick google and a stroll through the forums finds lots of "connection dropped" issues. Packets are often dropped because there is not enough memory to keep the state of all TCP connections that are made by the clients. This is a common problem for COTS "routers" regardless of firmware (DD-WRT has a wiki about a related issue here).

Try accessing your router via ssh (or telnet) and looking through /var/log/messages for anything from ip_conntrack (the kernel module that is used to keep track of connection state). You'll likely find something like this: ip_conntrack: table full, dropping packet.

I see you have already adjusted the ip_conntrack_max setting to the maximum of 4096 but try verifying that using the command line (cat /proc/sys/net/ipv4/netfilter/ip_conntrack_max). If your WRT150N has a decent amount of memory (e.g., 32MB or greater) you can manually set ip_conntrack_max to a number larger that 4096 (see here).

How many clients do you have behind your WRT150N? Are you using an P2P protocols? It has unfortunately been my experience that Linksys hardware and DD-WRT kind of suck especially in situations where there is any real kind of network traffic. It might be time to graduate to more robust solution.

Not the answer you're looking for? Browse other questions tagged or ask your own question.