1

I'm getting the following error out our httpd error_log.

How do I go about solving the conflict?

[Mon Oct 03 09:28:46 2011] [warn] Init: SSL server IP/port conflict: atmail.webmail:443 (/etc/httpd/conf.d/zzz_atmail_vhost.conf:48) vs. horde.webmail:443 (/etc/httpd/conf.d/zzz_horde_vhost.conf:41)
[Mon Oct 03 09:28:46 2011] [warn] Init: SSL server IP/port conflict: WEBSITE1:443 (/var/www/vhosts/WEBSITE1/conf/httpd.include:12) vs. horde.webmail:443 (/etc/httpd/conf.d/zzz_horde_vhost.conf:41)
2

This warnings comes up because you are using multiple SSL certificates on one IP: http://httpd.apache.org/docs/2.0/ssl/ssl_faq.html#vhosts

Solutions:

  • add another IP to the server.
  • enable TLS Extension Server Name Indication (SNI)
| improve this answer | |
1

As quanta has said, you've got multiple virtual sites configured to use the same port (443) on the same IP address. You might benefit from reading the answers to Can I run two different secure sites using the port 443 on the same server? ; getting more IP addresses for your server is a common and excellent solution, but it's not the only one.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.