Recently I grabbed some preconfigured CentOS 5.0 instance from EC2 and installed our stuff on it from rightscale. The instance was a little old, but I assumed that it would be up to date after a single yum upgrade.

However, for reasons beyond my understanding, CentOS is not updated beyond 5.0:

[root@ip-10-102-63-111:~] yum upgrade
Loading "installonlyn" plugin
Setting up Upgrade Process
Setting up repositories
Reading repository metadata in from local files
No Packages marked for Update/Obsoletion
[root@ip-10-102-63-111:~] cat /etc/redhat-release
CentOS release 5.0 (Final)

The repositories are active and even my EPEL packages are being updated, but it seems that the person who created this instance somehow fixed it at 5.0. However, I really need to update to the latest 5.x. How can I get yum upgrade to work again?

| improve this question | | | | |
  • 1
    Can we get the output of "yum repolist?" – Rilindo Oct 4 '11 at 20:30
  • Mad - yes I forgive you :-) And thanks for mentioning this, I was not aware of these courtesies. Actually I assumed that the right answer was decided by voting from all members. Anyway I'll go over my previous posts when I have some time. – Jeroen Oct 4 '11 at 20:54
  • Rilindo - there is no such thing as yum repolist ? Do you mean yum list or yum grouplist maybe? – Jeroen Oct 4 '11 at 20:57

Ah I solved the problem. Taking a close look at /etc/yum.repos.d/Centos.list revealed that the version was hardcoded in the repository url, e.g:


So I replaced "5.0" with "5" in every line and then did a yum clean all followed by a yum upgrade which updated me straight to CentOS 5.7.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.