I have a Windows 2008 Server with Hyper-V installed, and a couple of VMs.

All was working properly until I tried upgrading BIOS. All of a sudden I get permission denied when attempting to start any VM, saying 'general access denied error' on the vhd file.

Error message

I have attempted the fix at: http://support.microsoft.com/kb/2249906 and http://techblog.mirabito.net.au/?p=275 - both with the same result.

Also SYSTEM, and NETWORK SERVICE accounts have full access.

How can I fix this issue?

*Edit: Even creating a new virtual machine + disk is giving this error, but I can inspect an existing disk, and even expand it without problems. Also cdrom device is giving the same error. If I remove all harddrives and cdrom devices from settings, I may power on the VM without any 'General access denied error'.

*Edit2: I attempted to completely remove Hyper-V and reinnstall it again - same result.

| improve this question | | | | |
  • "If I remove all harddrives and cdrom devices from settings, it starts." this doesn't make sense what starts? – tony roth Oct 4 '11 at 22:14
  • The VM can be powered on (naturally it can't load any OS tho) – Jon Skarpeteig Oct 5 '11 at 9:28

This seems like an odd error to get in response to a BIOS upgrade. If you're certain those files are in those locations and the access control lists haven't been changed, I'd look at the BIOS itself. A BIOS upgrade can frequently reset the BIOS to its factory default settings. Perhaps virtualization itself is turned off.

| improve this answer | | | | |
  • Virtualization bits were turned on again after bios reset, and the files are there – Jon Skarpeteig Oct 4 '11 at 20:58

Adding the user NETWORK SERVICE to the group Administrators solved my issue.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.