We moved site to Windows web server 2008 RS2 and now get error "The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access."

One of answers on similar question recommend look at web.config file. Here it is; POST and GET added to allowed verbs. What else I can do?


  • In order for us to answer this, you need to check what file is being requested. See "Requested URL" in the error page. If it's a *.json file, follow these instructions. uipress.com/add-json-handler-support-in-iis-7/#.UT_bw9aOR8E ... if it's some other file type, find out how to implement that type of handler mapping. – MacGyver Mar 13 '13 at 2:15

I encountered this error on a Windows 7 Ultimate OS, and this is what I did in IIS 7.5:

I ensured that the WebDAV module was uninstalled. Some of the http verbs (specifically PUT and DELETE) can be in conflict with the WebDAV module. You have to remove that from the "Programs & Features" area of the control panel.

I also added the DELETE verb to the "Request Filtering" area of my website within the IIS Manager and set it to Allow.

Finally, within the "Handler Mappings" area of the site in the IIS Manager I added a new mapping with the title DELETEVerbHandler, and used the following settings:

Request Path: * Module: ProtocolSupportModule Executable (optional): Name: DELETEVerbHandler

You probably will need to do the same thing for PUT and OPTIONS http verbs.

Hopefully, that will help, but this thread might have more details that can help you. http://forums.iis.net/t/1166025.aspx

| improve this answer | |
  • Perfect, solved the problem completely for me - particularly the Request Filtering and Handler Mappings section (note for others you should be using "Add Module Mapping" when doing the Handler Mappings step). This solved the issue for me with ASP.Net Web API. Thanks @ariestav – Zac Jul 12 '12 at 10:59

I would recommend the following instructions to solve this problem.

  1. Open WebDav Authoring Rules and then select Disable WebDAV option present on the right bar.

  2. Select Modules, find the WebDAV Module and remove it.

  3. Select HandlerMapping, find the WebDAVHandler and remove it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.