2

How do I detect if "Web Services Feature Pack for WebSphere "is installed in Websphere Application Server v6.1?

I need this information to solve some classloading issues while deploying cxf webservices in Websphere.

6

While I don't have the WSFP installed here, by far your best bet is to use WebSphere's versionInfo utility.

You can find it in %APPSERVER%/bin where %APPSERVER% is your WAS installation location.

Reference (from the WAS 6.1 infocenter) can be found here.

My suggestion is that you generate the version report in HTML using the most detailed flags (-long -maintenancePackages -maintenancePackageDetail -components -componentDetail) and take it from there.

  • versionInfo (.sh or .bat) is, indeed, the easiest way to do this. The installed Feature Packs will be listed there. – dbreaux Oct 5 '11 at 14:03
1

One quick way to detect if the Web Services Feature Pack is installed is to look at the top of SystemOut.log file:

************ Start Display Current Environment ************
WebSphere Platform 6.1 [BASE 6.1.0.XX cfXXXXXXXXX] [WEBSERVICES 6.1.0.XX cfXXXXXXXX]
0

My guess is that the original requester of this post is having trouble with getting the Web Services Feature Pack to be in use, even though they have installed it. I ran into this same problem with WAS6.1, and discovered the following points that might be useful to the requester. The WSFEP enables the use of SOAP 1.2, whereas without it you are stuck with SOAP 1.1.

Verify that you have installed the web services feature pack by running versionInfo.bat as described above. You should see it listed in the output if it has been installed. Also check that the base and web services are at the same fixpack level.

The web services feature pack (WSFEP) could be installed, but won't appear in existing profiles. You must create a new profile after installing WSFEP and specify during the creation whilst using the profile management tool that you wish this profile to use the WSFEP. Next you should look for the existence of the WebServices.jar file under the WAS_HOME directory path. Once found, you should check that it was last changed at the date and time when you installed the WSFEP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy