2

Unable to access NFS shares on Ubuntu from Windows 7. It just acts like the share can't be found on network. (NET HELP MSG 1222)

on client:
added NFS features
tried "mount IP:/share z:" and the gui drive mapping
tried with and without "AnonymousUid""AnonymousGid" DWORDs under HKLM\SOFTWARE\Microsoft\ClientForNFS\CurrentVersion\Default
firewalls are off

on server:
exportfs lists the shares.
mount shows "nfsd on /proc/fs/nfsd type nfsd (rw)" (I think that's normal?!?) have experimented with many options in:
/etc/exports
/etc/default/nfs-kernel-server
/etc/default/nfs-common
tried forcing no NFS v 4 after each change I'm restarting nfs service and re-exporting

Is there a log I can look at somewhere?!? I've been trying to figure this out forever... Any help would be much appreciated!

2

I once ran into a problem connecting to NFS shares from Windows 7. For me, the solution was to do the following on my Windows machine:

  1. Open group policy editor (type “edit group policy” in the windows search bar)
  2. Expand the tree selection to Computer Configuration->Windows Settings->Security Settings->Local Policies
  3. Select the Security Options item
  4. Disable the policy named “Microsoft network client: Digitally sign communications (always)”
  5. Restart your computer
  • You're a freaking genius! Thank you! WHERE did you find this?!? – bumbling fool Oct 7 '11 at 9:15
2

As always look in /var/log/syslog first.

  • Thanks, but nothing relevant is there. – bumbling fool Oct 7 '11 at 9:15
  • Or var/log/messages - depends on the distribution – Al Bundy Oct 19 '17 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.