4

I changed /etc/sudoers file rights to 0740, because I wanted to edit it as root. I could edit it.

What is happening now is that I can't change it back to 0440. I can't sudo anymore. I always get this error message :

sudo: /etc/sudoers is mode 0740, should be 0440
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin

Does somebody know how to get back to normal ?

2
4

If you have the root password then you can use su to gain root permissions and change the perms on the sudoers file.

$ su -
Password:
# 

Another option is to boot into single user mode. To do this restart your system and at the grub screen press Esc. Select the kernel you want to boot and press e selct the kernel line and press e again. Append S to the end of the line and press Enter then press b. This will take you to single user mode and allow you to change the perms on /etc/sudoers.

Note that Ubuntu systems may have a (recovery mode) option which boots to single user mode already configured in grub.

3

iain's suggestion is better, but if that isnt an option for some reason, you can add init=/bin/bash to the kernel line in grub at boot time which'll normally drop you to a root shell.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.