The client machine is running 64 bit Windows 7 and attempting to copy a relatively small file to our NAS device. The NAS device is a Lacie model running (I believe) some variant of Windows XP and has no permission structure aside from access/no access.

Approximately one out of five uploads will be successful. The others will fail at varying times during the upload process and this is visible by the progress bar on the copy dialogue freezing and eventually failing (network location cannot be reached).

So far I haven't been able to isolate the problem. I'm looking for further steps that might help.


The NAS is online and has plenty of disk space.

This issue seems to be specific to this one machine. I can't reproduce it on anything else, even when copying to the same network location. The user is authenticated with the same credentials as the rest of the office (low security, general drop box).

I've ruled out a cable or switch problem by reproducing the issue wirelessly on the same machine.

Things to note:

Only uploads to the NAS fail. Downloads work normally and reliably. The file being transferred does not make a difference though smaller files have a better chance of completing before the connection drops.

Any ideas on how to pin this down?

  • Is the switch port and the system port set identically (i.e. 1G/Full Duplex)? Does the switch report any errors on the port you are using on either system? Do either system report network errors at all? – mdpc Oct 14 '11 at 21:56
  • I've had problems with Win7/Vista and NAS and CIFS with MS's default settings of Packet Signing. It was particularly bad with MYOB, multiple people sharing simultaneous access to the same file. Packet signing would cause a network session to drop leaving the file unstable. To turn off packet signing run GPEdit.msc: Windows -> Security -> Local Pols -> Security. Turn off all the "Digitally Sign" settings (take note of what they were so you can set them back). There's multiple settings and they're replicated for Workgroup and Domain networks. – Dom Oct 15 '11 at 6:11
  • Come to think of it my problem was exactly the same (except it was a Windows SBS 2008 Server). Uploading lots of small files worked. When I zipped them to make large files, and copied the directory again and again and again, once every 5 to 10 times it would fail. It took MS about a month working with me to narrow it down to packet signing. – Dom Oct 15 '11 at 6:18

Hmm, at first it sounded adapter related. But you've tried multiple adapters. That limits server or client issues.

I've similar oddball issues like this before:

Windows 7 and Vista have some TCP autotuning which I've had cause havoc in some smaller client setups when utilizing workgroup connections and some less than stellar network equipment.

To disable TCP autotuning you can run the following from an elevated command prompt:

To disable the system policy (and allow overrides per user level) netsh int tcp set heuristics disabled

To change tuning netsh int tcp set global autotuninglevel=disabled

For more information you can read up on the commands here. I'd recommend starting at disabled and seeing if that helps your problem. If not we are barking up the wrong tree and I'd recommend looking into reseting the TCP stack.

  • 1
    Sorry for the late confirmation but the issue was intermittent enough for me to be uncertain if it was fixed. I haven't run into this problem since so I think this answer is definitely helpful if someone finds themselves in my place in the future. Thanks. – Jack Dec 2 '11 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.