So, I have MS SQL Server 2008 running on a Windows Server 2003 machine in VMWare with a network interface set to host only.

When I run my 'application' on apache (xampp) on the host machine and connect to the MS SQL server with the IP of the Virtual Machine's Network Interface it works but it's extremely slow, just doing a select for one or two tables can take 10 seconds for the page to load.

However if I do the same but put apache, the same exact configuration, on the machine running MS SQL the pages load near instantaneously both in the browser on the Virtual Machine and the browser on the host machine connecting to the Virtual Machines IP.

Why do the query's take so long when apache and MS SQL are on different machine but not when they are on the same? The connection is done to the same IP with the same username and password in both cases and it's the exact same php sites loading...

Really hope someone might have an idea...


I would also try changing the port numbers just to see if there is a bottle neck at anypoint. I am not a vmware expert but If i remember even if your on the host setting I still think it resolves at NAT there for there for your computer has to make dns/dhcp which could be causing the slowness issue, try seeing if u can add it to your internal network therefore your nic will be acting with 2 ip address.

| improve this answer | |
  • Changing the port did no difference but setting the interface to bridged (connecting directly to the physical network) fixed it... Strange really strange... As I said, if I run Apache on the server and go to it via the host only IP it's very fast, odd how sql queries over the same link became so slow... Oh well, that did it at least. Thanks! – Leonick Oct 15 '11 at 20:36
  • @Leonick what i think caused it was the fact that when you do the direct to host link you have to crete a mini network router dns and all sort of stuff. An http request does not have to much data most times and http has had a lot of time to get bugs cleaned up but sql can have a lot of data depending on ur test data and any over overhead glade I was able to help welcome to serverfault.com – WojonsTech Oct 16 '11 at 5:13

Turn off TCP/IP Chimney Offloading on the VM, then try it again. That will probably fix the issue. Failing that, you may have to put wireshark on the server and see where the failures are starting.

| improve this answer | |
  • Just checked that out. TCP Offload was set to off for the network interface... – Leonick Oct 15 '11 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.