We recently had to move our site between hosts. We moved the files and the database and then changed the nameservers to point to the new host. After a little bit of fiddling the site at the new host works well and all problems are fixed.

Well almost all, there remains one largish problem.

Irish (and possibly international) users who use vodafone (you know - the worlds second largest mobile phone company) are still being redirected to the oldsite - which now no longer exists so they are getting a non-working site.

I could understand if there was a delay of a few days before vodafone updated, but it has now been 2 weeks and all vodafone customers are still being sent to the wrong place.

All our other website visitors can see our site, all other isps in Ireland are correctly seeing the new site, googles dns servers see the new site.

We are getting phone calls from people saying that the can't see our site, every single one of these people has been using vodafone as an isp.

What I've Tried

I have tried to phone vodafone, but because I'm not a customer and because our site isn't hosted with vodafone and because I'm trying to contact their network systems people they really couldn't care less.

I've tried waiting - I assumed if I waited 10 days it might get updated, but its been 2 weeks now and still incorrect.

  • What can I do to get vodafone to update the nameservers for my site?

  • Why do they treat this differently to every other network provider on the web?


According to http://www.who.is/dns/cookingisfun.ie/ The SOA record for my domain is

cookingisfun.ie SOA 4 hours     ns1.dreamhost.com. hostmaster.dreamhost.com. 2011100306 20842 1800 1814400 14400

This is correct. I'm afraid I dont have the old details. If there is a problem in the SOA record does that mean that vodafone follows rules that everyone else ignores?

Previous nameservers were ns.webfusion.co.uk ns2.webfusion.co.uk

If I do a NSLookup from my machine using the OLD webfusion servers I get


> server ns.webfusion.co.uk
Default Server:  ns.webfusion.co.uk

> cookingisfun.ie
Server:  ns.webfusion.co.uk

Name:    cookingisfun.ie


I will see if I can do that from someone who has vodafone as ISP

  • you should update your post with some information on the old and new contents of your nameserver zone - especially the SOA record part. There is a chance that this is not vodafone's fault but simply a problem with your zone data
    – the-wabbit
    Oct 15, 2011 at 14:44
  • no... SOA is content of your zone on your ns, both are unknown to us Oct 15, 2011 at 15:06
  • I've updated my question with more info.
    – Toby Allen
    Oct 15, 2011 at 15:12
  • about SOA - latest SOA as is is almost useless, you must to check, that after editing zone and zone-reload serial-number will change... or it (edit serial - 2011100306 in your case) must be done by hand before reload, can't recall old bind times in details Oct 15, 2011 at 15:15

2 Answers 2


I have done some lookups from the Vodafone DSL dialup network in Germany and they look fine - no problems resolving your site:

dig cookingisfun.ie a

; <<>> DiG 9.6-ESV-R1 <<>> cookingisfun.ie a
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55037
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;cookingisfun.ie.               IN      A

cookingisfun.ie.        14400   IN      A

;; Query time: 187 msec
;; WHEN: Sat Oct 15 21:25:48 2011
;; MSG SIZE  rcvd: 49

$ whois|grep -i vodafone
descr:          Vodafone D2 GmbH
org-name:       Vodafone D2 GmbH
address:        Vodafone D2 GmbH

Can't you just bully ns.webfusion.co.uk to remove the cookingisfun.ie zone from their nameservers or change the A-Record to reflect your new IP address? If Vodafone's nameservers have incorrectly cached that ns.webfusion.co.uk is authoritative for cookingisfun.ie and would not let go of that, this would help.

  • If I simply do a NSLookup on my machine I get the same as you, which is correct and current. The log above was what happens when I set the server value to the webfusion nameservers. This is exactly my problem you and everyone else in the world except for vodafone users are seeing the old / wrong broken site at
    – Toby Allen
    Oct 15, 2011 at 18:59
  • 1
    It looks like webfusion has changed the "A"-records but the "SOA" still points to ns.hosteurope.com. I wonder if they would ever drop the zone. If not, you still might run into problems upon another change of DNS records.
    – the-wabbit
    Oct 19, 2011 at 10:18
  • And I am backlinking your followup-question for further information.
    – the-wabbit
    Oct 19, 2011 at 21:35

I could understand if there was a delay of a few days before vodafone updated, but it has now been 2 weeks and all vodafone customers are still being sent to the wrong place

Some "big players" ignore RFCs and store cached data in ns-caches even after TTL expiration. You can do nothing with it. For more deep troubleshoot I'll be happy to see results of dig or nslookup for your hostname from unhappy vodafone users (without censoring your hostname and IP)

  • I'll see if I can get someone to send me the info
    – Toby Allen
    Oct 15, 2011 at 15:06
  • Expire time in SOA too long, thus - secondary NS 21 day can give outdated data, if zone was not successfully updated from primary. Test case for you (I'm too lazy to do handwork) - get SOAs from all secondaries and compare serial to primary Oct 15, 2011 at 15:31
  • Does that mean at least it should update after 21 days?
    – Toby Allen
    Oct 15, 2011 at 18:36
  • No and yes, if secondary will not get updated zone for expire time period, they will stop answer on requests for outdated zone (old secondaries - I see you have changed NSes - will shut up and do not give out false information). Just note - without big picture all my thinking around expire time is just speculations and divination Oct 15, 2011 at 18:41
  • 1
    Is there a reason that Vodafone seem to be the only network operator working in this particular way?
    – Toby Allen
    Oct 15, 2011 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.