I'm unable to get mysql to run on Redhat, basically parallels power panel attempted an update and sent me an email stating that it failed, stopped the service and can not start it.

mysqld.log states

[ERROR] /usr/libexec/mysqld: unknown variable 'set-variable=local-infile=0'

I'm able to get the service to start again by deleting everything in "/etc/my.cnf" I'm looking at the configuration file but, I'm not entirely sure what it does, from what I've read it deals with some of the security aspects of mysql though so I'm uncomfortable just deleting it and continuing to run the database as is.

Would there be a safer fix for this? or is this acceptable? I'm not as experienced with mysql or linux distros as I'd like to be.


CHeck your mysql configuration file for the line that is being reported,


It sounds like my.cnf has 'set-variable=local-infile=0' in it and your version doesnt support that parameter.


Your mysql-packages seems to be destroyed or wrong configured during the update. Try to reinstall them from your base-repository:

  1. For now I may advise you to dump all databases like:

    # mysqldump -uadmin -p`cat /etc/psa/.psa.shadow` --all-databases > /root/mysql.full.dump
  2. Then uninstall all MySQL related packages:

    # rpm -qa | grep mysql
    # rpm -e --nodeps `rpm -qa | grep mysql`
  3. Then use Plesk Autoinstaller and install them back again:

    # /usr/local/psa/admin/bin/autoinstaller
    Next > Next > Next:
    11 [x] MySQL server support
  4. Start MySQL-Daemon again

    # service mysqld start
  5. After that you may restore your databases:

    # mysql -uadmin -p`cat /etc/psa/.psa.shadow` < /root/mysql.full.dump

Don't forget to install php-mysql again - enjoy!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.