1

I am running VMware Workstation 6.1.5 (build-126130) on CentOS 5.3 (Final).

One of the guest machines is reporting an error when I try to power on the most recent snapshot. Snapshots further back in the timeline will power on without any problem.

Error: Unable to change virtual machine power state: Cannot find a valid peer process to connect to.

VM Power State Error

Others have been reporting this problem since at least early 2005. The forums say to delete unused lock files and restart any hung VMware processes (or restart the host machine), which I have done.

Still no luck. Any other ideas?

1

I tried to clone the snapshot before making more changes, just to have a backup, and that failed too.

Cloning failed: reached the host's limit for open files.

Cloning failed error message

Thinking the errors are related, I looked into how many files are actually part of this VM. The list was HUGE.

I have 13 snapshots before the one giving me trouble, so I tried deleting a few of them to reduce the number of files VMware would need to open. This fixed everything. I could have increased the max number of open files, but many of those snapshots were not needed any longer.

0

I had the exact same problem today. In this case I saw that the VMware is closed un expectedly but the ubuntu login is still active. I opened the PUTTY and login to my ubuntu again. login was successful. Then I used poweroff command to shutdown my ubuntu session.

After that I could re-launch my ubuntu from VMware.

Regards Pintu India - Bangalore

0

After a power down, starting the VM using vmrun start produced:

Loop on signal 11 -- tid 4409 at 0x3616407638. Error: Unknown error

Using the GUI gave another kind of error: "Cannot find a valid peer process to connect to"

Deleting lock files didn't help. Restarting the server didn't help neither.

Following Robert's hints about too many "old snapshots" , it seems that VMware Workstation 8.0 is using some kind of file quantity quota. I proceeded to delete my oldest snapshot (using the GUI) and this resulted in the machine being able to start from the freshest snapshot. It is now up and running OK.

My environment is CentOS 5.7/64 on both the host and the VM.

This seems to work... may be it's the solution to this problem. It had gone twice through this, but was able to reconstruct from snapshots. This last time (today), it wouldn't run even from a snapshot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.