I have a server with Win2008R2 and a synology NAS. On the Nas there are 6 iSCSI partitions which are mounted on the windows server. The windows server is virtualized under Hyper-V.

After rebooting the client machine, two of the 6 partitions do not remount and I have to manually remount them... every time.

Each one has a similar configuration and has been configured with CHAP authentication. All 6 appear in the favourites list.

Event log shows no errors regarding iSCSI. The other 4 partitions mount without problems.

Any suggestions for further debugging?

EDIT: After speaking with synology they suggested disabling chap authentication and enabling something called masking, which is basically a filter to block which nodes can connec to each LUN. This made a huge difference to the problem. It still occurs every now and again after power outages or similar, but after reboots I can be pretty much certain that the luns will remount. I guess its an issue between the windows iscsi initiator and the target in authentication negotiation.

  • Have you checked the logs on the NAS? Oct 26, 2011 at 1:03
  • Good thinking, I hadn't checked that. However, it doesn't say anything. The log is almost empty.
    – Ian Murphy
    Oct 26, 2011 at 11:06

3 Answers 3


Apart from Favourites list have you checked if the volumes are listed in Volumes and Devices tab in iSCSI initiator properties? And are they set to Auto Configure?

This should (in theory) make sure that all volumes are initialized.

Auto Configure Volumes


  • This list is empty on this server and every other server I have using iSCSI. Any idea what purpose this serves as against the favourite targets. They appear to do the same. Favourites are reopened after rebooting, and so are what appears in this list. Saying that, I've just tried out the 'auto configure' button and it has added drives in the form D:\, E:\, etc and not as appears in your screenshot above. Odd, no? I seem to remember trying this in the past and not finding it useful.
    – Ian Murphy
    Oct 26, 2011 at 10:43
  • According to the second paragraph in the dialog, you should have your initiator in the Favorites, and your individual devices in the Volumes and Devices. You could try removing all of the devices, then add them back in via the Auto Configure button. Oct 26, 2011 at 14:47
  • Thanks for the visual aid ;). Much appreciated. I too think clearing the devices and readding them back via Auto Configure could help.
    – LukeP
    Oct 26, 2011 at 21:28

Make sure add to favorites and enable muilti-path is selected when you connect to targets:

When you discover portal, click advanced, don’t use defaults click “Microsoft iSCSI Intiator” and you’re NIC IP for Initiator IP.

  • I tried all the suggestions above and I still see targets not remounting. This occurs on all versions of windows and at multiple clients. It also occurs with different makes of Nas, so it can't be down to a poor Nas implementation... unless they're all based on the same libraries. Perplexed to say the least. I should also mention that I have also seen luns disconnecting in windows when a Nas is rebooted. Some luns will reconnect, others will simply disappear. Others will remount but be offline in windows (occasionally)
    – Ian Murphy
    Jun 20, 2014 at 12:14

Rather old thread, but running into the same problem these days with Windows Server 2008 R2 SP1 and a Synology RS18017xs+ with DSM 6.1.5-15254. Checked the above "auto configure" suggestion, but it does not work for me. The solution from this guy worked for me:

  • Remove the auto configured device
  • Click "Add...", and manually specify the drive letter or mount point - 'F:\' in my case

Just for the records.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.