I've just tried setting up a postfix/dovecot server for the first time, with accounts managed through a mysql table. (via tutorial at http://library.linode.com/email/postfix/dovecot-mysql-ubuntu-10.04-lucid)

If I log into the actual box, the mail server works. If I send mail to a user (from either the local or remote domain) then login to the box via SSH & type 'mail', the logged-in user's mail shows up.

However, when I try to access the mail via thunderbird, it says 'no messages'. It says the server details are fine, it accepts the password - but, well, no mail. Have tried in both IMAP & POP3.

Any ideas how to go about diagnosing this? I'm completely at a loss.


1 Answer 1


Did you configure mail to access your mail using POP3/IMAP? If not, it will directly access your mbox.

Have a look at your maildir dovecot is using: mail_location = maildir:/home/vmail/%d/%n/Maildir and also the directory ~/mbox (default mbox directory).

Try to monitor /var/log/mail.log, without further information from there we won't be able to fix that problem.

  • Hi Ranon - thanks for the quick response. In /etc/dovecot/dovecot.conf mail location is set to maildir:/home/vmail/%d/%n/Maildir, but oddly enough mail was going to ~/mbox only. At a suggestion I wrapped quotes around the connection= param in dovecot-sql.con - it's now set up directories in the correct vmail directory...but I'm getting incorrect username/password errors when trying to set up the server in Thunderbird (I didn't get them before). I can still connect to the servers through SSH & am at a loss - have double-checked pretty much everything.
    – unclaimedbaggage
    Oct 19, 2011 at 15:58
  • Did you configure postfix (guess you're using this as MTA) to deliver mails to dovecot? When it still stores your mail in the mbox something's wrong with your postfix-configuration. If you send mails to some mailbox on the server they still arrive?
    – Ranon
    Oct 19, 2011 at 16:08
  • Hi ranon...yeah - in theory I did, but you're right - that mbox shouldn't be happening. I'll try starting from scratch with postfix/dovecot/saslauthd; hopefully something clicks.
    – unclaimedbaggage
    Oct 19, 2011 at 16:13
  • I would try to configure a simple installation authenticating against your shadow-file or similar and adding database support afterwards. That's a lot at once and quite error-prone - I remember some friend having lots of troubles getting his mailserver to authenticate against a database.
    – Ranon
    Oct 19, 2011 at 16:15
  • Yeah - cheers. I'll verify each step a little more thoroughly this time.
    – unclaimedbaggage
    Oct 19, 2011 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy