I've already looked a lot for this issue but coudn't find the answer, I hope you can help me

I was working on a Windows 2008 Server using some python scripts to update and compute some values from a few mysql tables, stored on MySQL Server 5.5.

But we had a power failure which turned off the computer and when we turned it on again, everything was fine, but we totally lost connection to MySQL. Basically any attempt to run mysql service brings up this message:


The mysqld service is not running. We''ve tried to restart it, basically by following the steps presented in the mysql documentation site:




But nothing fixed the problem. When typing net start mysql, i get the message:

"System Error 5. Access Denied"

After reading the documentation, I've found this command: mysqld --debug, which presented the message:


I don't know if this message can give any hint of what's actually going on, I hope it does. We've tried everything we've found on the internet: restarting the server, resintalling mysql server, running updates and so on, but the mysql service still won't start.

And no error log was created at all...(but we still don't know if our tables are ok)

Running a mysqlcheck on all databases, I've got the following message:

"mysqlcheck: Got Error 2003: Can't connect to Mysql Server on 'localhost' (10061) when trying to connect".

Does anyone know how to fix it or at least know how to restore the tables we already had before the power outage?

I really appreciate any help! And if you need some more information please let me know! Tnx!

  • Give more details on what you tried when restarting, and exactly the outcome and/or error. Oct 23, 2011 at 3:11
  • I've re-edited the post trying to give more information. Tnx for the help!
    – Will
    Oct 23, 2011 at 17:17

3 Answers 3


Try running the command prompt as administrator. You should be able to right-click the command prompt shortcut and click "Run as administrator."

Then, do the commands you tried earlier.

  • I've tried it and even though the commands didn't fix mysql I got different messages at this time. This one probably is the key issue: "System Error 1067". I got it running 'net start mysql'. So I googled it but nothing from what I found was useful. I've tried removing then reinstalling, mysqld --console, mysqld -debug, mysql install -defaults-files=<my.ini>, but nothing worked so far... I read that when mysqld is abruptaly interrupted when updating a table it may occur this type of 'crash', but there was no solution along this info. Any suggestions? Tnx in advance!
    – Will
    Oct 24, 2011 at 2:58
  • I found something: if I type 'mysqld --no-defaults' mysqld is able to start and I can initialize workbench. But I don't have access to the old tables and python can't connect to mysql by this strategy
    – Will
    Oct 24, 2011 at 23:35

Is your mysqld process running? You can open task manager > Processes tab and sort by image name.

Or try this: Open commant prompt and go to bin directory of mysql installation if your mysql service is msql type this:

.\mysql\bin\sc qc mysql You should see something like this: [SC] GetServiceConfig SUCCESS


If not then you need to start/set up mysql as service.


Two things you can do:

  1. Ensure the directories and files in the MySQL data directory have the correct permissions and try restarting the MySQL service.
  2. Reinstall MySQL (this is my preferred option). Existing data and configurations should not be affected but the installer will ensure any corrupted files or permissions get replaced with good ones.

You must log in to answer this question.