I am struggling with a strange error when I try to commit my repository. I have a V-server with webmin installed on it. Via Webmin I installed an svn module, created repositories and everything worked fine until three days ago. Trying to commit brings the following error:

Commit failed (details follow):
Server sent unexpected return value (503 Service unavailable) in response to
PROPFIND request for '/svn/rle/!svn/wrk/a1f963a7-0a33-fa48-bfde-183ea06ab958/RLE/.htaccess'
Server sent unexpected return value (503 Service unavailable) in response to
PROPFIND request for '/svn/rle/RLE/.htaccess'

I google everywhere and found only very few solutions. One indicated that a wrong error document is set, another one dealt about the problem that filenames might cause this error and last but not least a wrong proxy configuration in the local svn config could be the reason.

After trying all of the solutions suggested I could not reach anything. Only after a server reboot there was a little difference in the error-message, telling me that the server was not able to move a temp file, because the operation was permitted. So I also controlled the permissions of the svn directory, but also with no success.

An svn update than restored the "normal" error from above and nothing changed since then.

The only change I made on the server, I guess that this could be the reason why svn does not work anymore, was to install the php5_mysql module for apache via apt-get install php5_mysql.

Atg the moment I have totally no idea where I could search. I don't know if the problem is on my server or in my repository and I would be glad to get any hint to solve this.

Thanks in advance Greetings philipp

error log:

[Tue Oct 25 19:23:02 2011] [error] [client] Could not create activity /svn/rle/!svn/act/d8dd436f-d014-f047-8e87-01baac46a593.  [500, #0]
Tue Oct 25 19:23:02 2011] [error] [client] could not begin a transaction  [500, #1]
[Tue Oct 25 19:24:21 2011] [error] [client] Could not create activity /svn/rle/!svn/act/adac52c2-6f46-f540-b218-2f2ff03b51a4.  [500, #0]


<Location /svn>
DAV svn
SVNParentPath /home/xxx/svn
AuthType Basic
AuthName xxx.de
AuthUserFile /home/xxx/etc/svn.basic.passwd
Require valid-user
AuthzSVNAccessFile /home/xxx/etc/svn-access.conf
Satisfy Any
ErrorDocument 404 default
RewriteEngine off

The permissions for the repository directory are : rwxrwxrwx (0777). the directory


does not exist on the server. I think this is part of the repository.

So, I just just want to admit that i tried to reach the repository via Browser and i worked, I could see everything, so the error only occurs when I try to commit new files. I also created a second repository and tried to commit files in there, what gave me the same error.

After a longer time of investigating the www with no success, i could find help from a friend and it figured out that the svn was working correctly, the permissions where set right and the conflict, which is not solved actually, might be caused somewhere in the apache configuration or in the providers settings (strato). Relocating the repository to https://... solved all problems and worked just like it had never failed to.

So, if anybody has an idea, why http does not work, while https does, it would be nice to let me know.

p.s.: mod_proxy was enabled on my server all the time, but svn was working with http at the beginning.

  • What does the Subversion config look like? Post the content of .htaccess files? Is there any interest in the error log? – quanta Oct 26 '11 at 14:20
  • which subversion config do you mean, the local one, or the from the server? – philipp Oct 26 '11 at 14:24
  • I mean from the server. – quanta Oct 26 '11 at 14:29
  • Can you clarify what you did to the permissions, and show us what the permissions look like now for the location that it's failing on (/svn/rle/!svn/act/adac52c2-6f46-f540-b218-2f2ff03b51a4) and its parent directories? – Shane Madden Oct 26 '11 at 15:32
  • Are you running SELinux? – quanta Oct 27 '11 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.