I have a development server that is running CentOS 5.x. I have two 4TB drives that use eSATA that I use for backups. When I got these drives I learned the version of parted in CentOS 5.x did not support GPT or files systems larger than 2TB but after using gparted-live the kernel still was able to support them. I have not had problems with these disks.

I now have a 3TB USB drive that I need to do a one time archive of some files to and am not having any luck with getting it mounted. Linux see's the physical device but not the partition on it. If I try to list the partitions with parted, parted will crash. Oddly enough fdisk can see the partition.

I tried repartitioning a couple times using Fedora 15 once and gparted-live once. When I plug the drive into my macbook pro running fedora 15 in VMware the VM can see and mount the partition just fine.

So right now I am back in gparted on fedora 15 and labeled the device as a msdos partition layout and setting up 3 partitions and will use LVM to combine them. Hopefully this will work (its partitioning and formatting as I type this).

My question is does this make any sense? Can the interface ( USB vs eSATA ) have this effect? The 4TB drives using eSATA work flawlessly. If it is the interface is it likely a hardware implementation issue or a CentOS 5.x issue?

  • Realized an error in my logic. I cant make the disk a msdos layout if its 3TB regardless of the individual partition sizes. For what its worth the first 2 1TB partitions worked when I did this and then when trying to use the third one I was getting errors from pvcreate and pvdisplay saying it was a duplicate PV of the first partition. – digitaladdictions Oct 27 '11 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.