This is my first server fault post (more of a stackoverflow guy).

We have several shared drives (on Win Server Standard 2008, SP2), which intermittently seem to lose a connection during the day. Within My Computer on the client machine(Windows XP), it still shows the drive without any folders/files within. I've tried to remap the drive manually or disconnect that drive and map again, which both fail. When I log onto the server and go to Manage the Session for that share, it is showing that a session is currently open for the user that is unable to see the folders in that share. I have also tried running a gpudate /force to see if it was a group policy error, which is always unsuccessful. The only fix is either logging off/in or rebooting.

Also, we have several Windows 7 machines which seem to experience this more frequently than our XP machines. Not sure if that is of any use.

Does anyone of have suggestions for fixes or diagnostics? Thanks.

  • What other information would be helpful to the experts out there? – chalbert Nov 1 '11 at 19:06

First thing I would check is the Event Viewer on the Windows XP/Windows 7 machines to see if Windows has logged any errors in the Application or the System log that give an idea why it is losing the connection. My guess is that you'll see something about the machines being unable to contact the server or failing to authenticate to the server.

Also I'd try remapping the drive in a Command Prompt. That might give you more detail on why it is failing than remapping in Windows Explorer.

Another thing to check for is third-party software loading into Windows Explorer that could be interfering. Get the free Process Explorer utility from Microsoft and run it on one of the machines with this problem. Open up My Computer and then select the explorer.exe process from the list of processes in Process Explorer. Choose View -> Lower Pane View -> Dlls from the menu to get it to show the list of DLLs that are loaded into explorer.exe and check for any non-Microsoft DLLs that are loaded into Windows Explorer. We've experienced problems with mapped drives that were resolved by uninstalling Novell and Roxio software, both of which were loading DLLs into Windows Explorer and weren't even required anymore on our estate.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.