We use windows server 2003 for DNS on our network. The forward DNS entries ("A" records) for windows machines on the domain are populated automatically. However, the reverse DNS entries ("PTR" Records) are not. The reverse lookup zone exists, and I can add entries to it manually, but it doesn't automatically populate the client IP are still in forward lookup zone DC.local. Dynamic updates are enabled for both the forward and reverse zones. On the DCHP Pool I have Enable Dns dymanic updates according to setting > Dymanically update dns A and PRT records only if requested by DCHP Clients Tick in Discard A and PRT records when leased is deleted

DNS I set Scanege stales records every 3 days on Forward Lookup Zones and Reverse lookup zone 3 days

  • 1
    What is your question?
    – Sam Cogan
    Nov 3 '11 at 11:40
  • I believe the question is why aren't PTR records being automatically populated.
    – uSlackr
    Nov 3 '11 at 12:35
  • Are the clients windows? If so, have a look at one of the client's LAN Adaptor properties, TCP v4, Advanced, DNS and see if the checkbox "Register this connection's address in DNS" is ticked.
    – Dom
    Nov 3 '11 at 13:55

Not much to go on but here is a suggestion

First of all go to a computer that is correctly registered in the forward lookup zone but not in the reverse zone. Release and renew the ip from DHCP by issuing the following commands in a command prompt (elevated if client OS is Vista/Win7):

ipconfig /release
ipconfig /renew

If the PTR record does not show up in the reverse zone after renewing the lease, check out the security settings on the reverse zone. Make sure that the computer account for the DHCP server has the "Create All Child Objects" permission.

If you want to be absolutely sure that it works use the Enable DNS dynamic updates according to the settings below and then Always dynamically update DNS A and PTR records options on the DHCP server.

When you use the "only if requested by DHCP clients" option, you need to ensure that the network adapter on the client computer actually does register with the DNS server. To ensure this, the TCP/IP settings from the network adapter properties, press advanced and go to the DNS tab. Check the Register this connection's addresses in DNS checkbox

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.