19

When sending large email to a new CentOS6 server running Postfix as the MTA, the following message is returned:

tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 552 552 5.3.4 Error: message file too big (state 18)

I found the following suggestion, but am unclear as to where it needs to be added in the main.cf file:

This was caused by Postfix and it's limit on not only messages but mailbox sizes.

I had to add this setting in /etc/postfix/main.cf:

message_size_limit = 31457280

How can the maximum mail size (including attachments) be increased in Postfix?

17

Add it anywhere in main.cf, it's not relevant :) But it's good to keep directives grouped in some logical manner, it is easier for maintance

According to official postfix documentation:
message_size_limit (default: 10240000) The maximal size in bytes of a message, including envelope information. Note: be careful when making changes. Excessively small values will result in the loss of non-delivery notifications, when a bounce message size exceeds the local or remote MTA's message size limit.

Additionally, the default mailbox size of 50M may prevent mail from being delivered, especially after increasing the permitted message size. To increase maximum per user mailbox size, add mailbox_size_limit = <size in bytes> to main.cf.

Additionally, as Ian Sparkes commented, if you are using a virtual mailbox configuration, you might need to set virtual_mailbox_limit = <size_in_bytes>.

  • 3
    If you are using a virtual mailbox configuration, you might need to set virtual_mailbox_limit = <size_in_bytes> Took me ages to find this, no one seems to talk about it. ;) In the end if found it by invoking postconf and scanning for likely looking candidates. – ISparkes Dec 7 '16 at 9:21
  • The default message size limit is 10240000 Bytes = 10 MB, not 50 MB – 黄雨伞 Dec 20 '16 at 18:52
  • 1
    @黄雨伞 - mailbox size and message size are different, and described in this answer differently – warren Jul 18 '17 at 14:47
  • 1) 2018. 2) Giving mail sizes in byte units. WTF. – David Tonhofer Nov 16 '18 at 21:10
10

Yes, you are correct: message_size_limit is the configuration directive you need. Put it anywhere in the main.cf file and reload (or restart) Postfix.

You may use the postconf tool to check the currently configured value:

postconf message_size_limit
7

Be careful if setting this limit to a high number. You need at least 1.5 times the size of message_size_limit of free space on the partition where the Postfix queue resides. If you don't have that free space, then all messages are rejected even if they are only a few kilobyte in size. And if you receive one message of this size and then the space exceeds (during final mailbox delivery) all further messages are rejected. Due to missing space.

Also note: Email is not a file transfer protocol. See this QA: Why do we still have such small email attachment filesize restrictions?

3

Don't forget to set

virtual_mailbox_limit = <size_in_bytes>

if you are using a virtual mailbox configuration. Took me ages to find this, no one seems to talk about it. ;)

  • 2
    Appreciate the comment - but this would be better as a suggested edit to the existing answer and/or as a comment on it :) – warren Dec 4 '16 at 22:22
  • 2
    You are right, I moved it. Will delete this answer. – ISparkes Dec 7 '16 at 9:38
  • you should delete this answer :) – warren Mar 16 '18 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.