1

I was trying to add an ip address to windows firewall for remote desktop connection but I don't know why now I can't access to server via rdp even from old ips. I have administrator user and password of the remote machine. Is there any way to connect again via rdp?

Server is Windows Server 2008 R2 Web Edition

Edit: Also I have another server on the same network which I can connect via rdp.

5

If you can do remote registry, remote service console or psexec to the box you can shut down the windows firewall and / or update the rules to allow yourself back in. My preferred method is with psexec.

Assuming you can psexec the command should be:

psexec \\remotecomputername netsh firewall set service remoteadmin enable
psexec \\remotecomputername netsh firewall set service remotedesktop enable

EDIT - these are depreciated under Server 2008 but they should still work.

You also may want to execute this command from the other server on the same network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.