Extensive searching proved fruitless (and aggravating), so I'm moving from lurker to poster, finally! :)...

I have an HP ProLiant ML-350 G4p that I just converted from SCSI to an SAS/SATA machine (swapped out drive cage and switched RAID controller to a Smart Array P600). I initially bought 4x 1.5TB SATA drives (cheap Hitachi drives from retail, BTW), and I set those up on Port 1i with Great Success. The configuration is RAID 5 and has worked great for a month+.

I got the itch to both max out the drive cage ("why have empty bays??", I thought), extending the array with one drive and making the 6th drive a live spare to help ease my sudden paranoia pangs about having this much data in one place. (I debated switching to RAID 6, but chose RAID 5 + hot spare, instead. As a side note, if anyone disagrees with this, please advise?)

At this point, I found out that I can't get drives to recognize on port 2i! The drive doesn't show up in the BIOS array editor, and the light indicator in the drive tray is a solid amber light. This amber-lit situation is the same no matter which drive(s) I have plugged into port 2i -- I've swapped cables, moved drives in the cage, and I ultimately even got a replacement P600, but it has the same behavior. I tried every combination of card/cache/cable swapping I can think of and the result seems to simply be that anything plugged into port 2i will just light up amber. grrr

I've looked for jumpers or switches or BIOS settings that maybe would help, but I'm really stuck now that I have a 2nd adapter that behaves the same way.

Does anyone have ideas on what could be going on? I greatly appreciate your spare time.

Thank you! Paul

More info, in case it matters:

  • System has 2 power supplies, but only one plugged in at the moment (just saving power for now)
  • Neither the BIOS RAID config utility, nor the boot CD ACU(?) utility show that there are more drives plugged in besides the working array of 4 drives. Once the "initializing..." boot sequence for the P600 finishes, the port 2i drives show amber and the config utilities just say "there are no physical drives available" when I try doing things like adding a hot spare, etc. The drives are lit up solid amber before the app even opens up, anyway.
  • The drives are all the same, down to the manufactured date.
  • Can't think of anything else to add.. hope I've been thorough enough.

[EDIT: Nov 9, 2011 -- pHoza] I am still unable to discover how to make this work with both ports on the P600, so I have decided to move on the suggestion of ewwhite and I've bought a Smart Array P400 to try. I hope that ends up providing a solution for me to get all 6 drives on-line, but I won't know until next week, after I get the part and get it installed.

I am absolutely willing to continue testing and hopefully figuring out what's going on with the P600 in my configuration (I'm returning one card, but I'll have the other here for testing.) If anyone comes up with more suggestions to try, I'll run the tests and report back. I'd love to patch a "SOLVED!" onto this thread! I hate when things like this get left hanging. Unfortunately, I don't have funds to purchase more drives (SAS/SATA) to see if maybe it's just a weird incompatibility with 1/2 of this card and the consumer drives I'm using.

Thank you VERY much for your responses thus far, ewwhite.

[EDIT: Nov 22, 2011 -- pHoza] Well, I've bought a P400 card to replace my P600 and it's working great for me. I still don't know what else to think of the P600 2nd port issues, since it was the same with 2 cards. It really makes no sense that the same drives will work on port 1, but not port 2... oh well.

If it turns out anyone adds to this thread with something they'd suggest to try, I would be willing to put the P600 back in to test the theory(ies).

Thanks again to ewwhite for the help. I'll "close" this issue by accepting his post. (The P400 tip rocked. Thanks!)

  • Which OS are you using?
    – ewwhite
    Commented Nov 7, 2011 at 20:52
  • I'm on Ubuntu Server 10.04.3.
    – pHoza
    Commented Nov 8, 2011 at 0:09

2 Answers 2


A few things to check...

  • Have you upgraded the controller's firmware to the latest version 2.04? Often times, HP controllers introduce new or improved functionality in the form of firmware updates.
  • The Smart Array P600 controller is one of HP's first attempts at SAS/SATA connectivity. It's still a PCI-X card, so it may not be fully compatible with the drives you're using. It's rated for 1.5G SATA (versus the more common 3G and 6G now).
  • You're using consumer disks. There could be an issue there.
  • I'd recommend upgrading the firmware of your server as well to the most current revision.
  • Make sure you're working with current version of the SmartStart CD for Array configuration. Older versions of the software may have problems with that capacity of drive.
  • If all else fails, look for a used Smart Array P400 controller. Your server has two PCI Express slots. Those would be better suited to storage controllers than the PCI-X slot you're using now.
  • BTW - RAID 10 may make more sense with the size of the disks you're using. Lower rebuild times, better performance, etc.
  • Thanks for response... - Firmware has been updated on both cards - The thing that throws me regarding drive compatibility is that the first four drives worked right away and without issue on the Port 1i connection. I worried about that, but since it works on one port, shouldn't it likely work on the other? These drives are all as identical as possible. - I'll check into the software versions you mention and get back after confirming, thanks! - I'll research RAID 10 again and re-assess. TYVM. (Sorry, I'm struggling with formatting, as I'm new around here for posting..)
    – pHoza
    Commented Nov 8, 2011 at 0:04
  • (Still unsure how to format these replies better.. they get bunched up)... It turns out I do have an old SmartStart CD version (7.91), so I'm burning a new one of those (8.70). I do have what appears to be the latest firmware disk ("Smart Update Firmware DVD" - v9.30) which I used to get the 2.04 update for the P600s. I needed that update before it recognized the large drives in the first place, but after that, the Port 1i drives worked right away, without issue. I'll report back if the new SmartStart CD provides help.
    – pHoza
    Commented Nov 8, 2011 at 0:45
  • Additionally, RE: P400 vs P600.. I'm a little annoyed I didn't try harder than getting a P600, but I was trying to just replace the old SCSI (641?) adapter, hoping it would provide the easiest transition. I found this, for reference in this thread, which has stat comparisons between P4/600, as well as others: "ProLiant serial family" data sheet
    – pHoza
    Commented Nov 8, 2011 at 0:49
  • I am still unable to get anything recognized on the 2nd internal port (port 2i), but port 1i works great. I appreciate having a new SmartStart CD version now, but it's not having any benefit because the P600's BIOS isn't recognizing stuff on the port anyway. Before I can even hit F8, the light on the drives plugged into 2i glow a solid amber. "No physical drives available" in either BIOS utility or ACU. Any more feedback from anyone who can think of why one port doesn't work with the same drives? Maybe it's a drive incompat., but then I'd think port 1i wouldn't work either. This baffles.
    – pHoza
    Commented Nov 9, 2011 at 5:53
  • Did you swap the cables on the controller side to see if it's the port or the backplane that's the issue?
    – ewwhite
    Commented Nov 9, 2011 at 9:42

Smart Array P600 array specs:

Given the increasing need for high performance and rapid capacity expansion, the SA-P600 offers the following maximum storage:

Up to 2.7 TB of total storage with 38x 72GB SAS hard drives.
Up to 1.4 TB of external storage per PCI slot with 2x HP StorageWorks MSA50 SAS enclosures and 20x 72GB SAS hard drives.

I hope this helps.


  • You've just copied and pasted from the RAID controller's specifications? The controller predated the 1.5TB disks that the original poster was using. How is this relevant?
    – ewwhite
    Commented Jan 31, 2013 at 12:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .