I apologize if this is a basic question. I've inherited a SharePoint 2003 server that has, apparently, always had this issue and I'm not all that familiar with the inner-workings of SharePoint.

Some background: The SharePoint 2003 application is on 1 server. We have no other SharePoint servers (not running a farm). The config database is on a separate server. Both those servers are on subnet A. We have 3 subnets in our domain. All the other machines in subnet A can see the SharePoint site. All machines on subnets B and C can't.

Things I've Tried: I found out what the error message was behind the IE "friendly" error page. It's a 504. That's a gateway timeout error, so I upped the SharePoint site timeout (I doubled it to 240 seconds) and then also upped the SharePoint search timeout (from 20 to 40 seconds). That didn't work. I tried flushing the DNS on one of the machines from subnet B. That didn't help. I then tried telnetting into the SharePoint server's port 80 which is the port the site is on from that same machine in subnet B. That did work, so I know that the machine can at least get to the port.

I'm just not sure why it can't see the site when it can contact the SharePoint server on port 80.

What should I try next? Is there a setting I need to look at that will make SharePoint visible to machines across multiple subnets on a domain?

Thanks in advance for the help!

  • What kind of device is routing between your various subnets? Can you setup a packet dump on or near that device to see if anything obvious is happening? Maybe run a capture on the sharepoint box?
    – Zoredache
    Nov 7, 2011 at 23:38
  • Wasn't able to get the packet dump going yet, but I did check the name resolution. It looks good.
    – kelleystar
    Nov 8, 2011 at 21:43

1 Answer 1


Change your name resolution to make sure it is going to the right server. When you spin up your first SharePoint site, it is firmly attached to the full URL as specified in the central admin console. Unless someone's added alternate paths, entering a different name or just an IP address you may get nothing which will confuse your troubleshooting.

If your name resolution is correct, it really does sound like an asymmetric routing issue.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .