1

we have a small instance running on ec2 of
voxilla/FreePBX-Asterisk-1.6.0.5-i386.manifest
which has been updated as far as i can see

We signed up for sipstation (because it removes half the configuration headaches)

my problem is sipstation says it is using
codec Priorities : ulaw | g729

my thought is that if the phones (gxp2000) arent using the same codec then the asterisk box is having to encode all of the phone data (overloiading the tiny processor and killing call quality)

current setup is

# Preferred Vocoder
# 0 - PCMU, 2 - G.726-32, 3 - GSM, 4 - G.723.1, 8 - PCMA,
# 9 - G.722, 18 - G.729A/B, 98 - iLBC

 In order :
 0,8,4,18,2,98,9,3

which (both?) should i change and is my thought process corect on the quality

1

You are right that the Asterisk box has to transcode the audio. I'd say try setting Asterisk and your phones to use GSM and see how it goes.

I'm guessing the G729 codec is what is causing the stutter. It requires more processing power that many phones cannot handle, especially if you're doing three way calling.

  • it shouldnt be affected by the phones because it is IVR and never gets to the phone ... hmmm – MarkKGreenway Nov 15 '11 at 20:09
0
  • Check out 'sip show channelstats' to give you an idea of what is going on
  • Make sure you aren't doing any call recording because that could kill your system
  • Make sure firewalls aren't blocking any packets
  • Make sure local bandwidth isn't being eaten up by a workstation streaming music, bittorrenting, etc..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.