I've got a VM on a citrix xenserver 5.0.0 machine that won't start. it was running fine until it was rebooted on a Fri afternoon, a few weeks ago.

Starting it from the (windows-only) xencenter GUI results in:

   "This VM cannot be started, as its network interfaces could not be
   connected. One of the NICs is in use elsewhere."

Starting it from the command line results in:

# xe vm-start uuid=88915b63-d794-e021-4f78-b03f46e352b0
Cannot plug VIF
VIF: 5dfd3886-8b48-20e5-4231-30284d7b185d

anyone seen this before? know how to fix?

I've tried deleting and re-creating the network interface for the VM. I've also tried booting the VM without any network interface at all. I've tried "xe vif-unplug –force uuid=5dfd3886-8b48-20e5-4231-30284d7b185d" (doesn't work, expects the VM to be running, not halted). In fact, I've lost track of all the things i've tried doing that haven't worked.

It turns out that any VM rebooted on this server won't start, either, and I can't even create a new VM on it so it's looking like it's a problem with the host rather than the guest VM.

hit me with the clue bat, please.


It turns out that the /sys filesystem had somehow become unmounted. I have no idea how that happened, and can't find anything in the logs or bash history.

anyway, I remounted /sys, and was able to run xen-bugtool. and restart the VMs. so, problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.