3

Apache 2.2.3 | PHP 5.1.6 | MySQL 5.0.77

I followed cacti installation guide to install latest cacti 0.8.7h on CentOS 5.5 (64-bit). The installation of PHP/Apache/MySQL went smoothly until I finished the setup, and came to the login page.

I can login http://.../cacti/index.php with admin account but the new page is redirected to the same login page with the message "Please enter your Cacti user name and password below"

This is a infinite loop!

If I use a wrong admin password I get the correct error message "Invalid User Name/Password Please Retype". [Same problem here]

If I login use Guest/guest account, "Error: Access Denied, user account disabled." displays.

The Cacti log file (./cacti/log/cacti.log) is empty.

I Googled and seems this problem has existed for a long time, but no followup solutions were found on the forum posts I found. Anyone can help me on this problem? If more information needed, please let me know.


Nov 18, 2011 UPDATE: I re-installed Cacti, this question remains UNSOLVED.

1

try to enable session.auto_start on php.ini or check your session.save_path

7
  • Enable session.auto_start does no help. session.save_path = "/var/lib/php/session", should I change it? – Andrew Nov 15 '11 at 2:24
  • BTW, for the "Required Packages for RPM-based Operating Systems", when I verify the package httpd and net-snmp, the following displays: [cacti]# rpm -V httpd S.5....T c /etc/httpd/conf/httpd.conf [cacti]# rpm -V net-snmp S.5....T c /etc/snmp/snmpd.conf S.5....T /usr/share/snmp/mibs/.index What does that indicate and will it be the problem? – Andrew Nov 15 '11 at 2:39
  • should be not problem. /var/lib/php/session <= is it writable by apache ?. i got the same problem with you last time. i checked on database cacti i was login successfully ( select * from user_log, you should see the result field, if it's 1 it's mean successfully ), but on the frontend it's still showing login page. – chocripple Nov 15 '11 at 3:54
  • Login successfully but return to login page, that's exactly the problem I'm facing. Have you solved this problem last time? Would it be a good idea to "yum install cacti"? – Andrew Nov 15 '11 at 4:08
  • 1
    yes, i solved it with change session.save_path to /tmp/, and enable session.auto_start. after you login successfully, check /tmp/ it's should be have file sessions like SESS_xxxx. i'm not sure you can install via yum (cmiiw, if you can it could be using old version). – chocripple Nov 15 '11 at 5:04
1

Login as admin, click on "User Management" Select the user you're trying to authenticate with. On the right corner click on: chose an action -> Enable -> Go

0

It may be worth taking a look at the domain of cookies returned by cacti and at what domain you actually use to open it. Helped in my case.

0

In my case this was caused by an errant rule in my Varnish configuration which was stripping out cookies with unset req.http.cookie; and unset beresp.http.set-cookie;. Varnish sits in front of everything, including Cacti, and needed to exclude Cacti from this rule.

Making the conditionals around these directives more restrictive fixed Cacti for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.