I'm trying to convert a couple of old Windows NT virtual servers from vmware to KVM. I tried almost all guidelines and how to I found around the web but with no luck.

I have the vmware virtual disk:


partitioned image. I converted the vmdk into qcow2 image with the qemu utility and I tried to use it with kvm:

kvm -hda test.qemu -vnc :1 -m 750

but I receive "error loading operating system"

I also tried with raw partitions I can mount through losetup and kpartx - same problem. I then tried to create an brand new image file with:

qemu-img create -f qcow2 test.qcow2 2G

I partitioned the new image file and I copied the original partition 1 to the new partition 1 with dd:

dd if=/dev/mapper/loop1p1 of=/dev/mapper/loop0p1 bs=128M

no luck again

I also tried with a single unpartitioned file:

qemu-img create -f qcow2 test.qcow2 2G

and I copied the partition 1 to the new image file:

dd if=/dev/mapper/loop0p1 of=test.img bs=128M

but when booting, I receive a black screen and the virtual machine hangs.

The bootloader is loaded successfully, because I also tried with a GRUB live iso and I receive the same screens and errors. Note that grub sees the Windows setup and give me the boot choice.

I have the suspect the problem is that the vmware machine is probably a scsi guest and in centos 6 (my system) scsi emulation is no longer supported. But in that case, where to change in Windows? I'm not so skilled with MS systems.


http://alter.org.ua/soft/win/uni_ata/ try to install this driver, and then boot the VM with the disk image in IDE mode. WinNT4 is quite old, so it's hard to recall known issues nowadays, but generally speaking, you might want to try to run the VM with ACPI support disabled, and make sure your guest OS is aware of the driver change from vmware scsi emulation, to qemu ide emulation

  • I am still working on that, the problem is that I can't either boot the machine, so it is quite difficult to me to install the generic ata drivers you provide. I also am trying with the windows NT rescue disks but it seems they don't see my attached hard disk. if I try to load your drivers through the windows rescue console, it fails. Windows 2000 rescue disks see my hard disk image and can enter it. no fixmbr or fixboot solve my problem. At this point I'm very frustrated because I might have to leave KVM and follow with vmware. – Luca Rossi Nov 16 '11 at 16:37
  • the drivers are meant to be installed BEFORE you take the NT setup from physical hardware to virtual. Moreover, frustrated or not, you can't expect support for NT4 in (almost) 2012, especially since MS don't support it – dyasny Nov 16 '11 at 17:08
  • you are definetly right. Thank you for your support. – Luca Rossi Nov 17 '11 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.