1

I am getting this error when I restart PHP:

Restarting PHP5 FastCGI Process Manager: php5-fpm failed!

I am now phpless. I did touch the config file, but I can’t undo it as I lost my connection and I did not back it up.

Here is my current /etc/php5/fpm/pool.d/www.conf with all the comment lines removed.

[www]
listen = /var/run/php-fastcgi/php-fcgi.socket
user = php-www
group = php-www
pm = dynamic
pm.max_children = 10
pm.start_servers = 5
pm.min_spare_servers = 1
pm.max_spare_servers = 5

chdir = /

What’s wrong with that? And what log file can I look into to find the reason it failed?

  • Which distro? Specify a error_log directive in the php-fpm.conf, under [global] section, try again and take a look at this. – quanta Nov 15 '11 at 6:07
  • I temporarily fixed it by copying/pasting a copy i found on the internet. I'll be away for the rest of today. -edit- debian squeeze – user274 Nov 15 '11 at 6:12
1

This happens to me when there's another process running that was spawned from php-fpm. For example, I have a page that runs ImageMagick from command line in order to create thumbnails from images. If I try to restart php-fpm while ImageMagick is still running then it will fail after a timeout of it waiting for the process to finish.

  • Thanks! My php still seems to run and wordpress is working, even after a restart fail. So do I need to something now with killall or can I just leave it be? – Aditya M P Jan 22 '13 at 6:55
  • Okay, I did service php5-fpm stop and started again and that worked. – Aditya M P Jan 22 '13 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy