Being the most qualified (read: still not qualified) to solve our persistent network issues, I've turned to serverfault for guidance. I've done some searching, reading related documentation on cisco.com and tried a bit of troubleshooting.

Here is the config:

  • 100mb synchronous connection from a business internet provider (tested multiple times at 100meg at the source)
  • Cisco 871W wireless point & router is where the WAN connection starts (this serves all our wireless). The only wired connection in the 871W is the Catalyst switch listed below.
  • Cisco Catalyst Express 500 (24TT) is where all the wired connections terminate.
  • About 20 Windows workstations and servers (AD/Webservers only).
  • Some services in EC2 including mail and other web servers/apps.
  • I've been TOLD cabling internally should be gigabit-ready.

Here are the problems:

  • generally slow download rates from the internet to the desktop/laptop
  • frequent "page cannot be displayed" errors in browsers-sometimes 3 or 4 reloads are necessary... often times CSS wont load or other content requiring the browser to connect to a different server.
  • slow speed within the LAN from workstation to workstation copying files. I would expect extremely fast data transfer workstation to workstation / server to workstation in this simple network.

Several things I need to admit:

  1. I'm not primarily a network guy.
  2. Funding is relatively low, I need to be the guy that finds the solution.
  3. I understand most of the terminology and most of the technology.
  4. Implementation is where I fail due to lack of experience.

Getting to the point:

I'm wondering whether experienced network admins think that our small network should be sufficiently served with our current hardware if configured properly... or if we should purchase new equipment and start fresh? If starting fresh is the plan, whatever that new equipment may be is a likely different question entirely.

If I haven't provided enough information, I will happily do some troubleshooting and update with the results. I have experience using wireshark and some other tools. Please let me know what you think would be most helpful and thanks in advance.


I forgot to add that the Cisco applicance will not finish loading the SDM Express console. It hangs every time at the "populating modules... DHCP". It eventually crashes and closes. I've rebooted the hardware and this still happens.

11/16/2011 AM: I was checking the alerts and logs on the switch and I noticed that the port from the 871W router was showing half duplex. I'm also showing 12,000 dropped packets in the past 17 hours on this port. I'm turning my focus here and will update when I can get into the 871 Router. As of right now, the SDM fails to completely load. I'm not very good with SSH, but I have to try at this point.

Additionally, 1 smartport is set on the Catalyst switch... and it's just one of the normally used ports for a workstation. This role of router is set to this port. Can this be something I need to change as well? The port that's actually the Router link (which then goes to WAN) is just set to other. All the other ports are set to 'other'as well. None of the 'G' ports are being used. I would think that the Router should be plugged into one of the G ports in the Switch.

11/16/2011 PM: I rebooted the Router tonight and reconfigured the switch so that the WAN is actually using the uplink port. I tried different ports on the router to see if the duplex issue would go away (if it was a bad port) and ther other router ports are disabled. I can SSH into the router and was able to show some of the settings. It tells me that all ports are enabled and are all 100-full or auto. None of the ports are set to half.

Knowing this, I assume that I need to update the OS on the router and go from there. At the very least... that's my next step.

11/22/2011: Being new to Cisco support, I didn't know much about their environment and workflow. Given that the issue is likely an IOS issue with the 871W Router, I've purchased a support agreement (SmartNet) with Cisco. I'll continue to update this with information, but it seems now (and Cisco agrees) that we first need to update the Router. Its currently running code from 2006. I should get the USB to Serial adapter in the mail today. That's the last part I need to get things moving, finally.

  • 1
    I know from the internal AP to the router is gig. I had a lot of problems with my 881W when we first got it years ago. But with the latest IOS its been solid since. Check to ensure you are on the latest IOS. Do you have a support contract with Cisco? They are very helpful. – xeon Nov 16 '11 at 0:39
  • No, unfortunately... No contract. – Ben Campbell Nov 16 '11 at 3:47
  • I have a contract now. I found that to update the software, one must... and it was not that expensive. – Ben Campbell Nov 22 '11 at 18:43

The 871W can hit 80Mbps bare routing with CEF. NAT or PPPoE drops it down to 25Mbps or so. CBAC drops it down to 12Mbps. See Cisco's performance list.

  • Thanks, that's helpful. I was a bit shocked to see the PPS values much lower than I expected. – Ben Campbell Nov 16 '11 at 2:03
  • Thanks, this was fixed yesterday with a replacement of network equipment. I replaced the 871W Router & CE500 Switch with a RV220W Router & SG200 Switch. For the money, the RV220W is incredibly fast and I now have a gigabit internal network that we can scale to about 800 Mbps if needed. – Ben Campbell Jan 9 '12 at 15:13

If I were a betting man, I would place my money on the NAT state tables on the 871W as the source of the problem. Many of these low-end devices have limited memory at their disposal and depending on usage patterns, their NAT state translation tables can fill up. When this happens, you see behavior exactly as you stated - connections failing until one or more "slots" open up in the state table.

Here are a few things you can do to troubleshoot. (sorry - I'm not a Cisco expert and as such, can't give you the exact commands you'll need to do this)

  1. Increase the max number of entries the router will keep in its state table
  2. Shorten the expiry of state table entries
  3. Completely swap out the device for a more capable device temporarily. You won't necessarily need to go out and purchase something - just find an old PC, make sure it has two or more network interfaces and then install PFSense. If making this change solves the problem, then you've located the issue.
  • Yes, we are considering a PFSense box as a potential solution. I will check into the tables tomorrow. Thank you for the info. – Ben Campbell Nov 16 '11 at 1:49

Be sure you are not using auto negotiate for the link speed or duplex settings. Set each device on the network (even workstations) statically to troubleshoot. I have seen the symptoms you have described with a duplex mismatch.

  • Turns out that both the switch and the router should be statically set. Using Auto between these two devices causes a duplex mismatch. If either port is set to auto (or both ports), duplex errors accumulate. Once we set the router and the switch to 100 full, everything fell into place. – Ben Campbell Nov 29 '11 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.