I'm trying to compile kernel-rt- from RHEL6 MRG source RPMs on Centos 6 x86_64 system.

It's first time I'm doing this, so I did research on how to do this properly. From what I found, I did:

rpm -ihv kernel-rt- 
cd ~/rpmbuild/SPECS
nano kernel-rt.spec 
rpmbuild -bb kernel-rt.spec 2> build-err.log | tee build-out.log

in kernel-rt.spec I've disbleed compilation of variants I don' need - ie compile only rt and firmware. Also defined not to build debuginfo.

After compilation finished, I've got in ~/rpmbuild/RPMS/x86_64/ two files:


but when I tried to install kernel, I got error message: $ sudo rpm -ihv kernel-rt- error: Failed dependencies: kernel-rt-firmware >= is needed by kernel-rt-

There was no folder ~/rpmbuild/RPMS/noarch - where I would expect it to show up.

Also, I've tried rpmbuild --rebuild kernel-rt-, but got same results...

What am I doing wrong? I've seen this question, but it suggests what I tried already and I want to build kernel myself, not use pre-built from SLC.

3 Answers 3


I'd still recommend using the precompiled realtime kernels if you're not making any drastic driver changes or other optimizations, but if you need to build your own, do the following to generate the proper packages.

rpmbuild -ba --without debug kernel.spec

This builds your kernel.

rpmbuild -ba --target noarch --with firmware --without debug --without doc --without perftool --without perf kernel.spec 

This builds the kernel-rt-firmware package.

  • yes i need to add drivers for my raid controller. I've built it using command suggested by you - still didn't get kernel-rt-firmware package built...
    – sashk
    Commented Nov 16, 2011 at 3:41
  • Maybe try adding the -with firmware to the build macro in the first statement. I don't have a system to test with at the moment. Also, which RAID card drivers are you trying to add?
    – ewwhite
    Commented Nov 16, 2011 at 9:59
  • 1
    of course I tried --with firmware - it does not help. LSI 9265-8i
    – sashk
    Commented Nov 16, 2011 at 13:50

I've not tried this myself, but there is a rt-firmware SRPM in the repo referenced in the question. Building that might provide the dependency.

  • 1
    It didn't compile properly to produce proper .rmp files. I didn't try if recent version compile, as I'm using precompiled RT kernels from Scientific Linux
    – sashk
    Commented Nov 14, 2012 at 0:25
cd ~/rpmbuild/SPECS
rpmbuild -bb --without debug kernel-rt.spec --clean

cd ~/rpmbuild/SPECS
rpmbuild -bb --target noarch --with firmware --without debug --without doc --without perftool --without perf kernel-rt.spec --clean

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .