I'm currently using VMWare Fusion on Mac OSX and I have a VM running. In order to sniff out the network traffic I ran the following as root :-

$ /Library/Application\ Support/VMware\ Fusion/vmnet-sniffer vmnet8 -w login.pcap -e

However, a file named login.pcap is not created - Is there something obvious that I'm doing wrong?

P.S. I've tagged this as "vmware-workstation" as I could not find appropriate tags. I would love to have used "vmnet8", "vmware-fusion".

1 Answer 1


I'm not familiar with vmnet-sniffer but have you tried using redirection instead of -w option:

$ /Library/Application\ Support/VMware\ Fusion/vmnet-sniffer -e vmnet8 > login.pcap

  • Hmm, yeah but the resulting output is not viewable using wireshark - basically the output of "-e"(headers alone) is written out into the file...
    – user44468
    Nov 18, 2011 at 8:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.