I am running a Ruby on Rails application called Redmine. It's been working fine, but today it's giving a 503 Service Temporarily Unavailable error. (It was initially set up by an employee who is now gone.)

I check the error log and it says:

[Mon Nov 21 11:03:30 2011] [error] (111)Connection refused: proxy: HTTP: attempt to connect to ( failed
[Mon Nov 21 11:03:30 2011] [error] ap_proxy_connect_backend disabling worker for (

Here's a chunk of my Apache config

<VirtualHost *:80>
  ServerName redmine.{domain}.com
  RewriteRule ^/(.*)$ balancer://redminecluster%{REQUEST_URI} [P,QSA,L]

<Proxy balancer://redminecluster>

I found this link: http://www.redmine.org/boards/2/topics/20561 which suggests I simply need to "start the redmine server." I've tried /etc/init.d/redmine start which gives me this output

=> Booting Mongrel
=> Rails 2.3.11 application starting on

The contents of /etc/init.d/redmine:

cd /var/redmine
sudo ruby script/server -d -e production

One thing I immediately notice is that it says instead of In addition, running top or ps -ef shows no record of a "mongrel" or "redmine" process. I've also tried restarting Apache before and after starting redmine. Not sure where to go from here.

  • 1
    Running netstat -ptan and checking what's listening on port 3000 will tell you what the name of your Mongrel process is. It's usually mongrel_rails or something similar, but it's conceivable it could be ruby or another name. – jgoldschrafe Nov 21 '11 at 17:12
  • Thanks - I tried that and there is nothing running on port 3000. Must mean /etc/init.d/redmine is failing somehow. – andrewtweber Nov 21 '11 at 17:13
  • @jgoldschrafe I figured it out thanks to your help. You should add an answer so that I can accept. – andrewtweber Nov 21 '11 at 17:22

Ok I figured it out, thanks to jgoldschrafe. I tried netstat -ptan and found that there was no Mongrel process running on port 3000 as there should have been, indicating that /etc/init.d/redmine was failing. Indeed, I removed the -d (debug) flag and found that there was a large error backtrace regarding a plugin that was installed recently. I removed the plugin and all is well now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.