0

I am trying to ping one of my local host and checking CPU process to see how "Ping of death" attack behaves. I tried to ping my other PC which is in local network with 192.168.44.2 IP Address. I tried this,

ping -l 5000 192.168.44.2

and I got error like this,

ping: -l flag: Operation not permitted

I am on MacOSX Lion. How can I remove this flag so machine can let me ping with preload?

Thanks for any direction!

3

I'm a bit out of touch with Lion but do you not need to use sudo for some of the more advanced ping options?

I've been using Ubuntu of late and I know I must use sudo to use the -i option to set a delay between pings of less than 0.2 seconds.

  • Exactly I needed sudo su, and than get more permission for power :) thanks – TeaCupApp Nov 22 '11 at 9:40
  • I can confirm this. I just tried it on my Lion box and it worked with sudo and gave the same "Permission denied" error without. – Ladadadada Nov 22 '11 at 9:40
  • sudo su, can you just sudo? Or where you being general there? :) – jwbensley Nov 22 '11 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.