5

I'm trying to set up VSFTPD passive hosting on my EC2 instance. I ran through these instructions http://www.synergycode.com/knowledgebase/blog/item/ftp-server-on-amazon-ec2 . However, when I tried to connect in FileZilla, I got

  • Command: CWD /home/lingiii/ftp
  • Response: 250 Directory successfully changed.
  • Command: TYPE I
  • Response: 200 Switching to Binary mode
  • Command: PASV
  • Response: 227 Entering Passive Mode (10,222,206,33,54,184).
  • Status: Server sent passive reply with unroutable address. Using server address instead.
  • Command: LIST
  • Error: Connection timed out
  • Error: Failed to retrieve directory listing

Where directory /home/lingiii/ftp is set to wrx permissions for user lingiii, group developers (of which lingiii is a member) AND I'm logging in as user lingiii.

Any advice?

  • 3
    It looks like you haven't set the pasv_address to the public IP (i.e. it used 10.222.206.33 as the address - which is an private address - implying either the wrong address was used or the value wasn't set). See if you can fix that, as it appears to be a communication problem between your client and server. – cyberx86 Nov 24 '11 at 1:44
  • Are there any updates to this question? – barfoon Mar 13 '12 at 21:28
6

As @cyberx86 said, vsftpd is sending the instance's internal IP address as the address the client must connect to in response to the PASV command, which the client can't connect to since it isn't running inside EC2. You need to use the pasv_address configuration option to tell vsftpd what the public IP of the instance is.

  • This should be the accepted answer! – atonyc Feb 23 '17 at 4:20
0

There is another failure which is not this one but it may be similar. If you are connecting in PASSIVE mode and you can connect to the server but the directory list fails. This may be caused because the port range specified in vsftpd.conf is not open in EC2 instance. You need to go to AWS EC2 console management panel to open the ports.

For more details, see http://www.pixelstech.net/article/1422865204-Install-and-setup-vsftpd-on-AWS-server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.