I am unable to setup MySQL Cluster on ubuntu servers. As a starting point I started from the link but I am not successful and the tar ball version I download is 6.3.45. As I wanted to test the mysql cluster, the Data node and SQL node are same but sql never appeared as connected(mysqld on sql node is running/etc/init.d/mysql.server start) in management node console and it looks like below.

[ndbd(NDB)] 2 node(s)
id=2 @ (Version: version number, Nodegroup: 0, Master)
id=3 @ (Version: version number, Nodegroup: 0)

[ndb_mgmd(MGM)] 1 node(s)
id=1 @ (Version: version number)

[mysqld(API)] 2 node(s)
id=4 (not connected, accepting connect from
id=5 (not connected, accepting connect from

On all the 3 machines mysql-server & client(apt-get install mysql-server mysql-client) were already installed and I completely stopped and also removed them at the system start up.

Now the mysqld is from extracted cluster tar ball(/usr/local/mysql/support-files/mysql.server). As for testing, I created a test database on both the data nodes but the tables are also not syncing on other node. I checked many links, configurations are remained similar in all the links but somewhere it's going wrong. Any more extra package is required?, Could anyone help me here? I am trying this for past 3 days.

Update 1:

Is there any bug with Ubuntu and mysql-cluster, I am still not successful with cluster 7. Everywhere it's same configuration and working for everyone and why not for me?. Anymore help? please!

Update 2:

Anybody give me working tutorial of mysql-cluster on ubuntu(10.04), just a successfully working guide...


Anybody take up and guide me please...?


Would recommend either MySQL Cluster 7.1 which is the current GA release or 7.2 which is the Development Milestone Release (planned as next GA). Both can be downloaded here: http://dev.mysql.com/downloads/cluster/

The Getting Started guide will help you get up and running: http://mysql.com/products/cluster/get-started.html#quickstart

  • I gave a try cluster 7, the result is same!! – user53864 Nov 28 '11 at 5:23

I got it working!. As I said I already had themysql-server and mysql-client installed from apt, this was causing the problem and I am not sure how this could be problematic with mysql-cluster when I stopped and removed them starting from system startup. Somehow I could see mysql-cluster doing it's job after removing the mysql from apt by,

#dpkg --get-selections | grep mysql

#apt-get remove mysql-client mysql-client-5.1 mysql-client-core-5.1 mysql-common mysql-server mysql-server-5.1 mysql-server-core-5.1

Don't know what the problem between mysql-cluster(build install) and mysql-server(from apt though it's not running).


Don't know what happened suddenly, it's not working since yesterday. Actually I am unable to find out the pkg requirement for mysql-cluster, is mysql-server or mysql-client should be installed and running along with cluster or a mysql-cluster alone is enough for running SQL(mysqld) and data nodes?. Now it's not woking, mysqld(/etc/init.d/mysql.server) is not starting and giving the following error:

Starting MySQL
 * Couldn't find MySQL manager (/usr/bin/mysqlmanager) or server (/usr/bin/mysqld_safe)

On another node(having same problem) I even tried copying /usr/local/bin/* to /usr/bin but still no use and it was showing the below error when I try to start mysqld in this machine:

................... * Manager of pid-file quit without updating file.

This happened after installing libaprutil1-dev(apt-get install libaprutil1-dev) on both the machines. Anybody has any working link of mysql-cluster setup on ubuntu?


I got the issues I had fixed here and it's working now!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.