We recently decommissioned an old Win2K3 DNS/DC server and replaced it with a new fancy Win2K8 DNS/DC server. Due to timing we didn't give the new DNS server the same IP address but added a new one.

The old DHCP settings were: DNS1: OLDMachine DNS2: Existing Machine

New DHCP settings are: DNS1: NEWMachine DNS2: Existing Machine

Some of the Windows XP clients are exhibiting strange behavior. We have done: ipconfig /flushdns ipconfig /release ipconfig /renew ipconfig /registerdns

and when we do

ipconfig /all

I see:

DNS1: NEWMachine DNS2: Existing Machine

BUT when I do nslookup foo

I get: Nonexistent DNS server OLDMachine

followed by a successful reply by one of the existing DNS servers.

What gives? How is this old IP still stuck in XP even though I've forced it to have new ones, cleared out the DNS cache, and even restarted the machine???

I checked and the machine is set up for DHCP and there are no hard-coded DNS entries in the Network config (nor in the little Additional tab either).

EDIT - Also looking at the System log shows: 1054 - Description: Windows cannot obtain the domain controller name for the computer network. (The specified domain either does not exist or exist or could not be contacted). Group Policy processing aborted.

EDIT 2 - Possible solution yet it is still busted...

I changed the DNS servers by hand and noticed that they were being over-ridden. There's a stupid group policy (dunno why, but I'll leave it) that was forcing the DNS servers; changed it however the clients can't access the domain (since the primary DNS is down -- why the hell won't windows try the secondary one that is working fine?!?!?)... So how can I force either a group policy override (so that the desktops can find the domain again) or somehow get the group policy back on their computers? Ugh...

(p.s. is it a good idea to have a forced DNS server policy in AD? It seems like that's the sole job of DHCP?)


Look in your DNS zone and see if there's still a NS record in existence for the old DNS/DC server.

| improve this answer | |
  • It was there; removed it and did the ipconfig junk yet the phantom DNS still is there – Matt Rogish Jun 29 '09 at 20:41
  • and by "phantom DNS still is there" I mean on the client PC, not in the zone – Matt Rogish Jun 29 '09 at 20:52
  • Is the zone AD integrated? Possible that the change hasn't replicated yet? – squillman Jun 29 '09 at 21:38
  • It is integrated but I forced replication and I checked -- all DNS servers report this clear – Matt Rogish Jun 29 '09 at 21:41
  • 1
    Have you tried giving the machine a static address and static DNS server info? Possible that the DHCP server is still handing out the old address? Maybe restart the DHCP service? – squillman Jun 29 '09 at 21:52

Try: net stop dnscache (stops the DNS lookup cache service)

... and then see if your results change.

Also, do you have any other LAN adapters (VPN adapters, Virtual machine adapters, etc)?

| improve this answer | |
  • I tried that then did the whole suite of ipconfig /... ; nslookup still tries to resolve from the old primary DNS... – Matt Rogish Jun 29 '09 at 20:41

hmmmm... Have you tried restarting the machine or at least restarting the "DNS client" service ?

| improve this answer | |

Have a look in your _msdcs entry in DNS, there's a chance that you may still have an entry to the old DNS server in there. You'll have to trawl through every node of this tree, but I think you might find it.

| improve this answer | |
  • There was the IP of the old DC in the _msdcs\gc folder but nowhere else – Matt Rogish Jun 29 '09 at 21:24

Thanks for all your help. The Resolution:

I changed the DNS servers by hand and noticed that they were being over-ridden. There's a stupid group policy (dunno why, but I'll leave it) that was forcing the DNS servers; changed it and restarted clients. They got the new group policy and all is well.

| improve this answer | |
  • May as well mark this as the answer. I can't imagine it won't save someone some hair-tearing someday... – Kara Marfia Jun 30 '09 at 12:56
  • I can't yet - I have to wait 48 hours :( but I will once that time expires :) – Matt Rogish Jun 30 '09 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.