I am having a hard time figuring out an issue while trying to mount a windows share in Ubuntu 10.04.


The problem is I am not able to mount a windows share using a serverLocalUser present in the windows-server. But I am able to use smbclient to access that same share using that same serverLocalUser. I am also able to mount the same share using a domain user who also has permission for that folder.

sudo mount.cifs // /mnt/share/ -o username=serverLocalUser,password=passcode

mount error(13):Permission denied Refer to the mount.cifs(8 ) manual page (e.g. man mount.cifs)

Troubleshooting done:

The following works:

  1. smbclient // -U localServerUser
  2. sudo mount.cifs // /mnt/share/ -o username=domainUser,password=passcode
  3. Mounting using the localServerUser using nautilus (which uses smbclient internally)

The following does not works:

  1. sudo mount.cifs // /mnt/share/ -o username=serverLocalUser,password=passcode,domain= WORKGROUP
  2. sudo mount.cifs // /mnt/share/ -o username=\serverLocalUser,password=pas scode

Thanks in advance for your help.




Try this:

sudo mount.cifs // /mnt/share/ -o username=<domain_name>/serverLocalUser,password=passcode

  • that also did not work. I get the same error. Also the serverLocalUser as I said earlier is not a domain user. It is a user created in that server locally. – sree Nov 28 '11 at 4:36
  • Replace <domain_name> with IP address, but use slash instead of backslash. – quanta Nov 28 '11 at 4:40
  • I had tried that too. sudo mount.cifs // /mnt/share/ -o username=,password=passcode and sudo mount.cifs // /mnt/share/ -o username=\serverLocalUser,password=passcode does not work – sree Nov 28 '11 at 4:51
  • The following worked for me now: sudo mount.cifs // /mnt/share/ -o username= NOTE:I did not give the password in the command line; so it prompted me to enter the password; and when I entered it worked. Thanks for your help quanta. But I want to use this in a non-interactive script which will run automatically at a given time. Any idea to make that working? – sree Nov 28 '11 at 5:05

Try this for RHEL6

sudo mkdir -p /mnt/dev_support

sudo mount -t cifs //10.98.xx.xx/project /mnt/dev_support -o username='10.98.xx.xx/administrator'


New version of mount.cifs now uses a specific domain option so you should use something like

 sudo mount.cifs // /mnt/share/ -o domain=domain_name,username=serverLocalUser,password=passcode

c.f. man mount.cifs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.