0

i'm running Apache 2 on Debian at my VPS. Naturally i have problem with restricted GD-library of my php package and i need to fix it (i need imagerotate() function). Before installing php-gd pugin it's necessary to update php 5.2 to php 5.3

my /etc/apt/sources.list is:

#deb http://ftp.ru.debian.org/debian/ lenny main contrib non-free
#deb http://security.debian.org lenny/updates main contrib non-free
#deb http://ftp.ru.debian.org/debian lenny main
#deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib

deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all

The problem comes after apt-get dist-ugprade executing:

/$ apt-get update
Hit http://packages.dotdeb.org stable Release.gpg
Hit http://packages.dotdeb.org stable Release
Ign http://packages.dotdeb.org stable/all Packages/DiffIndex
Ign http://packages.dotdeb.org stable/all Sources/DiffIndex
Hit http://packages.dotdeb.org stable/all Packages
Hit http://packages.dotdeb.org stable/all Sources
Reading package lists...
/$ apt-get dist-ugprade
E: Invalid operation dist-ugprade

What can cause this problem? How much should i wait while Reading package lists...? Is there any simple guideline for further php-gd installation?

1 Answer 1

3

You made a typo: dist-upgrade (in upgrade)

1
  • oh, really.. sorry for a stupid question..)
    – drdarwin
    Nov 25, 2011 at 16:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.