2

I am doing some IO intensive DB imports that run for several days now and the IO performance has dropped tremendously over times. The DB data files (log files) are on an ext4 formatted logical volume which is mounted with default options (did not specify something special in fstab). Since I just learned that ext4 enables write barriers by default: Q: Is there some way to disable write barriers online (i.e. while the file system is in use), because I cannot interrupt the import and don't want to restart it again. I am aware that

  • write barriers might not be the only thing impeding performance
  • it is a bad idea to have write barriers disabled on journalling file systems if data safty is important (e.g. on a production system)
5

This command should work.

mount -o remount,barrier=0 /my/mount/point
  • Well, doesn't this interrupt the running DB operations? – user462982 Nov 27 '11 at 14:30
  • It might lock I/O for a second or so. In my experience its generally safe. Perhaps consider checking with the software vendor to see if they say any different on the matter first. – Matthew Ife Nov 27 '11 at 14:31
  • 1
    It could also work better by specifically suspending the import process, remounting then continuing the import process. – Matthew Ife Nov 27 '11 at 14:33
  • Just tried and it seems to have worked without any problem. Thanks! – user462982 Nov 27 '11 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.