I Have a windows 2008 R2 Ent Server. I installed a Microsoft iSCSI Target 3.3 configured and everything was fine until one reboot. The iSCSI Service will not start.

You Can reproduct the error:

1 Install Windows Server 2008 R2 Ent. (64bit)
2 Run Windows Update
3 Run DCPROMO and make a new forest and new domain also
4 Download and install Microsoft iSCSI 3.3
5 Install one klient, join a domain and attache the storage
6 Check that everything are OK
7 Shutdown a klient
8 Restart a server.
9 enjoy your own error msg.

The log from event viewer:

Log Name: Application
Source: Application Error
Date: 2011.11.27. 17:40:12
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: storage.demo.local
Faulting application name: WinTarget.exe, version: 6.1.7600.16561, time stamp: 0x4e8e0274
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17514, time stamp: 0x4ce78f36
Exception code: 0x80000003
Fault offset: 0x0000000000017f32
Faulting process id: 0xcb4
Faulting application start time: 0x01ccad233b8b8a12
Faulting application path: c:\Program Files\Microsoft iSCSI Software Target\WinTarget.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 79785a1a-1916-11e1-aa26-b0487a82a2c2

I tried uninstalling the target service and reinstalling it, but upon reboot I still receive:

Log Name: System
Source: USER32
Date: 2011.11.27. 18:40:26
Event ID: 1076
Task Category: None
Level: Warning
Keywords: Classic
User: DEMO\**********
Computer: storage.demo.local
The reason supplied by user DEMO\******* for the last unexpected shutdown of this computer is: Other (Unplanned)
Reason Code: 0xa000000
Problem ID: 01
Bugcheck String: 
  • If you seriously want help from other people you really need to put an ounce of effort into crafting a coherent and well formatted Question. You are the one asking for help, the onus is on you to give the perception that our efforts aren't being wasted. – Chris S Nov 27 '11 at 18:19
  • 1
    Looks vaguely like the system is corrupted, maybe a partial service pack installation or something similar. Did you install all available Windows updates before installing the Target (the first time you installed the Target software)? Try running sfc /scannow and see what it finds? – Chris S Nov 27 '11 at 18:30
  • The systems are upto dated, the windows Update sad that :),, if update is the reason than why worked it before, till restart ? – Gergely Nov 27 '11 at 19:11
  • One + I uninstalled the target, and install again .... no way, becouse every install process go to unexpected shut down :( – Gergely Nov 27 '11 at 19:14
  • I did not ask if the system were up to date now. I asked if they were up to date before you installed the Target software. Did you run sfc /scannow yet? – Chris S Nov 28 '11 at 0:12

The problem appears to be that you are trying to install an iSCSI target onto a DC. Promoting a server to DC can mess with IP because you are effectively binding a NIC to domain services. There are other things going on under the hood in terms of how the DC will set security levels for other NICs. I'm not a AD expert I've just noticed things happen. Installing any service or even multi-homing a DC is generally frowned upon.

Having said that, in a test environment I've installed services onto a DC and used the iscsi initiator on a DC, with a storage target elsewhere. But I've never tried to make the DC a storage target, and I have to say that from a security point of view I can't see the rationale for doing this. But if you are really set on doing it, why not try using another free Windows-based iSCSI target?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.