3

We run a server with MySQL 5.5. 95% of the tables are set to the InnoDB engine.

However whenever I look at the my.ini file (using the MySQL Workbench) under mysqld section innodb is unchecked and OFF is selected in the drop down. I don't see this line added to the my.ini file when viewing with notepad.

Should I check this setting and set it to ON so we can utilize the enabled innodb settings (buffers & log file etc.) or does this not matter?

6

Innodb is the default storage engine, and it is loaded by default. I would consider this a flaw in MySQL Workbench. You can read more about the --innodb (and --skip-innodb) option here:

http://dev.mysql.com/doc/refman/5.5/en/innodb-parameters.html#option_mysqld_innodb

Notice that if you disable innodb, MySQL won't even start unless you specify a different default storage engine as well.

1
  • I was thinking it was a flaw but I wanted to double check – Jeff Nov 28 '11 at 15:55
2

Sounds like an issue with MySQL Workbench.

MySQL 5.5 has a default storage engine of InnoDB.

In fact, the option default_storage_engine is predefined as follows:

  • MySQL 5.5.4 and prior, MyISAM
  • MySQL 5.5.8 and after, InnoDB

There is another option called storage-engine, which was deprecated as for MySQL 5.5.3. Keep in mind that MySQL 5.5.8 was the very first GA release.

I would strongly suspect MySQL Workbench if it is coded to check storage-engine instead of default-storage-engine. This would allow MySQL Workbench to monitor older release of MySQL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.