I'm currently investigating a baffling issue on one of our user's laptops which has me pulling my hair out.

The user has Outlook 2003 and this has been connecting to our 2007 Exchange server for months with no problems. This morning, he logged a call to say that his Outlook was offline and he couldn't seem to send or receive any mails.

I've had a look and it seems Outlook will not go online at all. I figured it was likely a corrupt mail profile, so tried to create a new one - however, it won't resolve the username/server and continually throws up the "Outlook must be online or connected to complete this action" error. We have a few thousand other users on the Exchange and none are having this problem.

To cut a long story short, here's a list of fixes I've attempted based on extensive Googling - NONE of which worked

  • New mail profile
  • Checked all TCP/IP settings
  • Disabled local firewall completely
  • Can ping Exchange fine and resolve names fine
  • Uninstalled all network settings/drivers and reinstalled
  • Double-checked all DNS and Netbios settings
  • Cleared out route table and checked all Host files for any entries - they're all empty
  • Enabled encryption within Outlook and set option to manually connect
  • Exported (messaging subsystem) Outlook profile keys from registry on working PC and tried them on this laptop
  • Restarted Exchange System attendant
  • .................... and finally, I logged in as network admin - a completely new Windows profile - and attempted to set up a new Outlook profile to test, using my own name. The same issue happened again under that profile ...... can't resolve anything.

There are no other firewalls or security between the laptop and our mail server.

Any ideas?

  • And rejoined the AD Domain? – mailq Nov 28 '11 at 15:17
  • Just tried rejoining domain, no difference. – Gary Nov 28 '11 at 17:09

Did you check for viruses/malware?

If that doesn't turn up anything, run 'detect & repair' from within Outlook (under the Help menu).

  • Yes, I should have added above sorry - fully scanned for viruses and malware. We keep our machines pretty tight and up to date so don't suffer from many infections. I've also completely reinstalled Office. – Gary Nov 28 '11 at 16:35
  • Try the Outlook /fixmapi switch - start - run - outlook /fixmapi – Citizen Chin Nov 28 '11 at 16:43
  • Tried that, no better. – Gary Nov 28 '11 at 16:56
  • Noted a new problem though! - when I try and run an NSLookup, I get a message saying "The ordinal 1108 could not be located in the dynamic link library". Wonder if this is related? – Gary Nov 28 '11 at 16:57
  • Suspicious - like might be a virus suspicious. I know you said that you already scanned for viruses, but I would suggest either using another product, or something like TDSSKiller or Combofix. If neither of those will run, then try a bootable AV CD like Avira: avira.com/en/support-download-avira-antivir-rescue-system – Citizen Chin Nov 28 '11 at 19:03

Don't forget testexchangeconnectivity.com to help troubleshoot any issues with Exchange.


From another comment you posted, it sounds like you're having issues with your DNS client on that machine. I would run SFC /scannow and if that doesn't find anything I'd reinstall the OS, as painful as that might be!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.