As my Windows EC2 instance lives, starting and stopping many times a week, it evolves. These changes get saved to it's EBS volume, so state is persistent across reboots.

Now, periodically I backup the (evolved) EC2 instance to a new AMI (which creates a new snapshot) OR I backup the EC2's volume/disk to a new snapshot.

Either ways (I don't care), my Windows EC2 backups end as snapshots.

Question: How do I restore these snapshots into usable AMIs or instances? I've tried two methods:

Method 1) Snapshot -> image

In the AWS management web-console, when I right click the backup snapshots and select "create image", it seems to recreate an AMI but that AMI is marked as 'Linux' and virtualization is 'paravirtualization' (instaed of Windows and HVM respectively). The machine therefore never bootup (blank 'get system log')

Method 2) Snapshot -> EBS volume

Here I'm

  1. Making an EBS volume from the snapshot
  2. Launching a new instance from the old AMI
  3. Shutting down the newly launched instance (so it shows up as 'stopped')
  4. Detaching, deleting the (root) volume AWS created when I launched the instance in #2 above
  5. Attaching the volume created in #1 above as the root volume (/dev/sda1). Yeah, I know /dev/sda1 is Linux terminology, but I suspect the Windows OS is virtualized in the Xen hypervisor which is Linux based.
  6. Start the EC2 instance stopped in #3, this time with the latest volume attached (i.e. simulate a restore from backup).
  7. Machine never bootup (blank 'get system log', can't RDP either) :(

I wonder if I'm missing something here ...

2 Answers 2


Ok, so the answer happens to be Method 2 itself. It actually works but I had to wait over 30 minutes for the machine to come up. I never get to see the boot logs but maybe Windows schedules a disk checkup upon bootup and that takes a while? I don't know. I just waited, had lunch and tried afterwards and the machine was up :) !

Still don't know why method 1 fails.

  • 2
    Method 1 fails because I believe in the documentation somewhere it states that you can't use that feature with Windows, only Linux :(
    – gt124
    Jan 11, 2012 at 21:03

Creating an AMI from snapshot works only with windows.

  • 3
    Got any proof of this? Sep 11, 2013 at 8:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .