I recently performed a complete computer upgrade at work and I'm having some weird slowness issues with my workstations. All the computers are current i5's with 4GB of RAM..plenty of power etc. The server is a Dell PowerEdge with server 2008 R2. When I built everything up I had roaming profiles on and redirection; which I have since turned off. There isn't that much software installed on the workstations (office 2007, Microsoft online services sign in, radmin server, kaseya monitoring agent that has AVG network edition installed) The workstations are all Windows 7 Pro 64-bit.

For some of my users (mostly the ones who had LARGE amounts of data in their my docs) their computing experience is like they are using a P2 with 128MB of RAM or something.. they are just REALLY sluggish when performing regular tasks like opening internet Explorer can take 15 seconds and then the page just loads super slowly always displaying the spinning wheel. Every office application will go to not responding with basic tasks of like attaching a file to an email or opening a word document. When I check the task manager the CPU usage is always under 5% and there is plenty free memory

Now, when I log into the domain administrator account on the same computer everything is lightning fast and works as it should. I have tried turning off/uninstalling the anti virus, running programs in safe mode, nothing seems to do anything.

The following is what GPO's I have enabled on the server. For Desktop Policy's I have WSUS set, a domain power policy that makes their computers not sleep, and domain enabled RDP

For User policy I have documents redirection enabled (appData and desktop redirection is turned off). Offline Files are set to "prevent use of offline files - enabled"

Any help out there at all.. my users are about to kill me.


Yes, and any recent users I have added or if I create a new account works fine. I think I might be getting somewhere as I notice in eventvwr that I'm getting these errors.

  1. "Session Kernel Context Logger" failed to start 0xC0000035
  2. Custom dynamic link libraries are being loaded for every application. 3

{Delayed Write Failed} Windows was unable to save all the data for the file \April\AppData\Roaming\Microsoft\Windows\Cookies\index.dat. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

4. {Delayed Write Failed} Windows was unable to save all the data for the file \koala\Redirected Folders\April\AppData\Roam .. ox\Profiles\4vqph4m0.default\places.sqlite-shm; the data has been lost. This error may be caused by network connectivity issues. Please try to save this file elsewhere.

  1. Log Name: Application Source: Microsoft-Windows-Folder Redirection Date: 9/19/2011 10:38:16 AM Event ID: 510 Task Category: None Level: Warning Keywords:
    User: MIDLAND\april Computer: MH109.midland.local Description: Folder redirection policy application has been delayed until the next logon because the group policy logon optimization is in effect.

  2. Log Name: System Source: Microsoft-Windows-GroupPolicy Date: 9/19/2011 10:38:16 AM Event ID: 1112 Task Category: None Level: Warning Keywords:
    User: MIDLAND\april Computer: MH109.midland.local Description: The Group Policy Client Side Extension Folder Redirection was unable to apply one or more settings because the changes must be processed before system startup or user logon. The system will wait for Group Policy processing to finish completely before the next startup or logon for this user, and this may result in slow startup and boot performance.

So, I think it's pretty clear that the client computers are still trying to do a lot as far as redirection and I'm at a loss because it's all turned off on the server.

Hope this helps at all..I appreciate any help I can get.

migrated from superuser.com Dec 1 '11 at 5:48

This question came from our site for computer enthusiasts and power users.

  • Just because you disabled roaming profiles and folder redirection in the GP, doesn't mean that the user/computer accounts won't still be trying to use the shares they pointed at. If they don't exist anymore, you'll be waiting for them to time-out a lot, until you find all references (registry, etc.) and fix them. Have you tried a fresh 'regular' user account to see how it acts? – techie007 Sep 19 '11 at 16:36
  • Yes, and any recent users I have added or if I create a new account works fine. I notice in eventvwr that I'm getting these errors. – mtward Sep 19 '11 at 16:58
  • Move out some (1/2 or more) of that data in the user accounts my docs folder, see if it comes back to life. – Moab Sep 20 '11 at 2:31
  • do you have any redirection in the user object properties, at domain GP or both? Are the user-data migrated from older systems (xp, vista or 2003)? have you tried to remake an existent user copying only the real data (docs, mail, etc) without the windows files that are actually created when you remake the user? – n00b Sep 20 '11 at 14:15
  • This is a completely new server/domain/user account rebuild AND new workstations. All completely new, all I did was copy their raw data and place back in their user accounts once everything was complete. So one thing I did last night was created a new user and the redirection policies seemed to apply correctly. The only folder supposed to be redirecting right now is the documents and that is what it's doing. if i create a file on the desktop and check it's properties its on the local desktop. Not true for existing users.. the policy won't "take" on their machines.. ideas? – mtward Sep 20 '11 at 14:38

I think it's a problem with the application of the GPOs, but by steps...

  1. The "Session kernel..." event has some answers here and it seems to be an issue with ipv6
  2. A known issue with dlls
  3. In the next answer
  4. 3 and 4 are it seems to be the same issue with subfolders inside the roaming directory, all the docs i had found are only for 2003, hope they work; essentially the roaming directory contains all the files which are being roamed when the user changes of computer... will continue later.
  5. The event 501 seems to be a normal behaviour.
  6. The GPO isn't working at all.

I think that the changes in the GPO aren't working at all.

Try to separate the changes in differents GPOs with basics (for experience i must say that is better 15 GPOs with one change than 1 with 15 changes).

Look the problem with ipv6, maybe you've a bottleneck in your network.

If anything works but with new users it seems to work fine, make a script for rebuild the users database, restore data and rebuild security settings or make it one-by-one (it depends of the number of your users)

good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy