When I run the command

dfsdiag /testdfsintegrity /dfsroot:\domain\dfs full

I get the following error

Checking the registry of the namespace servers... Error: The system cannot find the file specified. Warning: Unable to verify the registry of the following namespace server: DC1

I have been trying to look what this does but can find anything on it.

  • Are you running this command with an account that has permission to access the registry on DC1? Does DC1 have a firewall that is blocking the command from running?
    – smassey
    Dec 2, 2011 at 16:20
  • I am running the command as domain admin, I have also tried running the command on DC1 and I get the same error.
    – OptimAdam
    Dec 5, 2011 at 8:44

1 Answer 1


The KEY was missing in registry


was Present in DC2 and DC3

  • Thanks for the lead. In my case, one of the servers was missing a value in one of the subkeys: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DFS\Roots\domainv2. Apr 20, 2017 at 2:01
  • We were getting clients picking up the wrong DFSN namespace root target, and dfsutil /PktInfo was returning AccessStatus: 0xc000003a. The failing DFS Namespace servers were all missing subkeys and values under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DFS\Roots\domainv2\<rootname> - now working fine.
    – Minkus
    Apr 18 at 16:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .