I need your help people ;-)

I have a problem with messages coming into our Exchange Server and ones going out through it. Basically, the messages are stuck in the SMTP queue.

A message will come into the server, I can see it listed under "Exchange System Manager", but if you list the properties of the message queue it says something like

00:10 SMTP Message queued for local delivery

00:10 SMTP Message delivered locally to [email protected]

00:10 SMTP Message scheduled to retry local delivery

00:11 SMTP Message delivered locally to [email protected]

00:11 SMTP Message scheduled to retry local delivery

etc etc

For outgoing message list looks like this:

10:55 SMTP: Message Submitted to Advanced Queuing

10:55 SMTP: Started Message Submission to Advanced Queue

10:55 SMTP: Message Submitted to Categorizer

10:55 SMTP: Message Categorized and Queued for Routing

10:55 SMTP: Message Routed nad Queued for Remote Delivery

And the end - since then status didn't change, message is in queue, I am forcing connection from time to time but without an effect.

I checked connection with smarthost (used telnet for that) and everything seems to work correctly, so the problem is probably on exchange side. I am using Exchange Server 2003 running on Small Business Server 2003. I don't have any antivirus installed on server. Remaining free space on each partition is over 3Gb, on partition with data bases - it is over 12Gb. All was working good and without problems since 2005, problems started in half of this june - messages started going out and being stuck almost randomly (I don't see a pattern yet, some are going out, some are not, some are going after several hours).

I don't know what to do, what to check more, so please, any ideas?

Best regards, D.


  1. Priv1.edb has 14,5GB and priv1.stm 2,6GB - together those files have more than 16GB - can it be the reason? If yes, then what?

  2. Indeed, I haven't thought that it can have something in common with my problem, but several users reported recent problems with Outlook Web Access - they can log in, they see the list of their mails, but they can't see the content of their emails. Although when they are connecting with Outlook 2003/2007 - there is no such problem, only with OWA there is.


So,.. It works now, and I have to admit that I am not really sure what the problem was (hope it won't come back).

What have I done:

  1. Cleaned up some mailboxes to reduce size of them

  2. Dismounted Information Store

  3. Defragmentated data base files ( I used eseutil: c:\program files\exchsrvr\bin> eseutil /d g:\data base\Exchsrvr\MDBDATA\priv1.edb )

  4. Mounted Information Store back

  5. ..and before I managed to do anything else - my queue started moving, elements which were kept there already for days - started moving and after few minutes everything was sent, both, outside and locally.

But: priv1.edb is still big (13 884 203 008), priv1.stm as well (2 447 384 576), so this is probably not the issue of size of the file. And if not this, so what was that?

And if that was issue of size of the file, then soon it will repeat - is there something I can do to avoid it ?

  • What size is your mailbox database?
    – JS.
    Commented Jun 30, 2009 at 12:05
  • Priv1.edb is almost 15gb.
    – Diav
    Commented Jun 30, 2009 at 12:19
  • The reason the issue may not be visible in Outlook 2003/2007, is that cached mode is enabled in Outlook
    – JS.
    Commented Jun 30, 2009 at 12:47

4 Answers 4


Everything works now, the problem was indeed size of data base file - both files together - priv1.edb and priv1.stm have reached 16 383 MB and I was using Exchange 2003 without SP2 (which has exactly 16 383MB as limit for data base file). I still don't understand why just before reaching this limit sending was randomized - maybe some messages were too big to pass already? Not sure.

In case somebody has a similar problem to mine, here are links with solution:

How to obtain the latest service packs for Exchange Server 2003:


Database Size Limit Configuration and Management (from 18GB up to 75GB):


Thank you for your answers and comments, you both helped me a lot !


I'm assuming that your Information Store is working and that users are able to get to their mailboxes, etc. If that's not the case, then we need to discuss that issue because it will cause what you're seeing in your post.

Have a look at this article from Microsoft: http://support.microsoft.com/kb/828938

It feels to me like your Information Store is having a problem, and the "Disconnected SMTP Mailbox" as described in the article is as good a place as any to start (assuming that your uesrs aren't having general problems getting to their mailboxes with Outlook).

If you are able to stop and restart the Information Store service, please do so and examine the Application Event Log for the messages described in the article. In particular, you're looking for source "MSExchangeTransport" and event ID 326, and/or "MSExchangeIS" event ID 1194.

If this is the case, there's a resolution procedure in the article, but it's not a click-for-click procedure (thanks, Microsoft). Find out if this is your issue first, and then we can get more in-depth with resolution.


Could be a corrupt message in the \Exchsrvr\Mailroot\vsi 1\Queue folder. Sort the files by date, and move the oldest file somewhere else. And repeat.

  • I don't think it's a "poison message" problem. My gut says Information Store problem what w/ the repeated attempts at local delivery failing. We'll see... smile Commented Jun 30, 2009 at 12:15

I had something similar and eventually tracked it to this: Our outgoing message limit was 20MB and someone had sent emails of 18MB. No obvious error messages and sometimes some messages seemed to go through but about 100+ messages were bunged up in various queues waiting to go to SMTP destinations.

I dleted the big messages and suddenly everything was going agian.

No log messages but we have a slow DSL connection (long way from phone co.) and my guess was time-outs on SMTP connection? Or maybe limits on other end?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .