I installed .Net 1.1 on a Windows Server 2008 (which already had .NET 4 installed). Afterwards, I started getting the following error:

HTTP Error 500.0 - Internal Server Error Calling LoadLibraryEx on ISAPI filter
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\\aspnet_filter.dll" failed 

I have tried running aspnet_regiis without success. I have also tried the suggestions by Rick Strahl but to no avail.

I have also removed .NET 4.0.30319 using the cleanup tool. When I reinstalled it, The error was still there. I have already removed 1.1 but still i get that error. Please help.

  • The problem is you have 2 backslashes in "C:\Windows\Microsoft.NET\Framework\v4.0.30319\\aspnet_filter.dll". To fix, go into your IIS website, go to "ISAPI Filters" and manually edit/remove the extra backslash.
    – Doug S
    Jul 1, 2016 at 18:54

6 Answers 6


From error one can observe that path mentioned was incorrect(Extra slash before .dll file). Edit ISAPI filter and edit the path to remove extra slash.

  • This fixed the issue for me. I think Microsoft needs to review their code and ensure they either don't include extra slashes in their built-in configuration settings, or else update their tools to treat doubled slashes as single slashes.
    – Zarepheth
    May 24, 2014 at 17:14

Resolved by adding a new asp.net site and assigning a new application pool.

  • 2
    The real problem is you have 2 backslashes in "C:\Windows\Microsoft.NET\Framework\v4.0.30319\\aspnet_filter.dll". To fix, go into your IIS website, go to "ISAPI Filters" and manually edit/remove the extra backslash.
    – Doug S
    Jul 1, 2016 at 18:56

This fixed the issue for me as re-creating the website didn't work:


This is worth reading, as long as the link lives, but in summary, there are 2 fixes

  1. (quick fix) Set the app pool's Enable 32-Bit Applications to true
  2. (ideal fix) Adjust the system.webServer/isapiFilters configuration setting so that IIS will use the correct dll when operating in 64-bit mode
  • Hi, just posting links is frowned on here as this information may disappear. Any chance you could edit your answer with a summary - it doesn't have to be hugely detailed, so long as it's enough to point people in the right direction if the link goes.
    – Dan
    Jun 16, 2012 at 16:08
  • Note that in the IIS Manager for IIS 7.5 I was able to select the problematic ASP.NET_4.0.30319.0 ISAPI filter, click the "Edit..." action on the right, and change "Framework" to "Framework64" directly in the editor that popped up. Fixed it for me!
    – JoshL
    Mar 1, 2013 at 23:24

The problem is the double backslash.

Go to your server and select "ASAPI Filter" and remove the second backslash from path ;)

Then from blog.clicdata.com:

Get a command prompt in administrator mode and go to C:\Windows\Microsoft .NET\FrameWork64\v4.xxx and run aspnet_regiis -r. This will re-register the right libraries

  • Thank you for your solution, but please to try to include the relevant information in your answer and not only the link, because links tend to die. I have edited your answer accordingly but feel free to improve on that.
    – HBruijn
    Jul 10, 2014 at 13:09

I got this error, too. Before you do any above stuff, just try below

  1. Click on your computer icon in IIS.

  2. On right side, click ISAPI filters

  3. Pick up the Filter name ASP.Net_4.0_64bit.

  4. Check if filter path have an extra \ preventing to load this dll, e.g.: %windir%\Microsoft.NET\Framework64\\v4.0.30319\aspnet_filter.dll -> %windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_filter.dll

  5. Restart IIS – should resolve the error.


enter image description here

I got same error in my 2008 server 64bit VM environment I did following and IIS works fine

  1. Go to IIS Manager
  2. Open Application pool
  3. Write click on DefaultAppPool go to advance settings and enable 32 bit application to true
  4. apply the same to settings to ASP.NET v4.0 ASP.NET v4.0 Classic Classic .NET AppPool

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.